Mouse/touchpad setting does not remember setting for "Two finger Scroll".

Bug #1443138 reported by stíobhart matulevicz on 2015-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Switchboard Mouse & Touchpad Plug
Fix Released
Medium
Unassigned

Bug Description

This System Setting is not remembered. Re-opening System Settings after ticking the option shows it unticked again.

Two finger scrolling seems to partially work in spite of this, but is very "hair-trigger". The slightest horizontal movement while scrolling triggers 'back/next' actions. Especially noticeable when web browsing.

[v0.3 Freya, running under VirtualBox on Apple Macbook Air 11"]

Cannot reproduce here, but I'm not on Apple hardware.

Ah, it seems likely that it's due to VirtualBox being used; it might be trying to be smart and sending back/forward keypresses, and elementary OS likely isn't seeing the trackpad hardware directly as it would if it was installed on disk.

Daniel Fore (danrabbit) on 2015-05-02
affects: switchboard-plug-keyboard → pantheon-plugs
Daniel Fore (danrabbit) on 2015-08-21
affects: pantheon-plugs → switchboard-plug-mouse-touchpad
Daniel Fore (danrabbit) wrote :

I'm going to mark this as "fix committed" since we just got a new plug and I can't reproduce here. If someone other than OP can reproduce, please set the status to "confirmed"

Changed in switchboard-plug-mouse-touchpad:
status: New → Fix Committed
milestone: none → loki-beta1
Cody Garver (codygarver) on 2015-09-16
Changed in switchboard-plug-mouse-touchpad:
importance: Undecided → Medium
Daniel Fore (danrabbit) on 2015-10-22
Changed in switchboard-plug-mouse-touchpad:
milestone: loki-beta1 → loki-alpha1
Cody Garver (codygarver) on 2016-08-12
Changed in switchboard-plug-mouse-touchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers