Time Format original value of clock-format is inaccurate [$25]

Bug #1577107 reported by Cody Garver on 2016-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Switchboard Date & Time Plug
Fix Released
Medium
Keith Bailey

Bug Description

The default value of org.gnome.desktop.interface clock-format is 24h. But when you view the plug it reflects AM/PM.

It only displays accurately once you change the value using the plug from the original value AM/PM to 24h then back to AM/PM, it finally becomes accurate.

Cody Garver (codygarver) on 2016-05-01
summary: - Time Format original value not read accurately
+ Time Format original value of clock-format is inaccurate

I can confirm. Looks like the combobox isn't bound to the settings properly. To reproduce:

1. Open Date & Time and set it to AM/PM
2. Close switchboard
3. Select the dconf key and 'reset to default'
4. Open Date & Time

Notice that it says "AM/PM" in the combobox, but the panel is in 24hr time and the dconf key is also 24hr.

Changed in switchboard-plug-datetime:
status: New → Confirmed
summary: - Time Format original value of clock-format is inaccurate
+ Time Format original value of clock-format is inaccurate [$25]
Cody Garver (codygarver) on 2016-05-04
Changed in switchboard-plug-datetime:
assignee: nobody → Keith Bailey (kbailey4444)
importance: Undecided → Medium
milestone: none → loki-beta1
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2016-08-11
Changed in switchboard-plug-datetime:
milestone: loki-beta1 → loki-alpha1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers