Missing files in Swift tarball

Bug #912193 reported by Thierry Carrez on 2012-01-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Object Storage (swift)
Medium
Thierry Carrez
Essex
Medium
Thierry Carrez

Bug Description

I compared the repository and the tarball generated by "python setup.py sdist" (the one we actually release) and found the following differences:

-babel.cfg
-CHANGELOG
-locale/
-locale/swift.pot
-test/unit/common/corrupted_example.db
-test/unit/common/malformed_example.db
-tools/
-tools/rfc.sh

It might make sense to fix this (both in master and milestone-proposed) before releasing 1.4.5 ?

Thierry Carrez (ttx) on 2012-01-05
Changed in swift:
milestone: none → 1.4.5
Thierry Carrez (ttx) on 2012-01-05
Changed in swift:
importance: Undecided → Medium
milestone: 1.4.5 → 1.4.6
status: New → Confirmed
summary: - Missing files in Swift 1.4.5 tarball
+ Missing files in Swift tarball

Fix proposed to branch: master
Review: https://review.openstack.org/2965

Changed in swift:
assignee: nobody → Thierry Carrez (ttx)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/2965
Committed: http://github.com/openstack/swift/commit/47346f6490d7e5bd397aa28afb96439da5d01d58
Submitter: Jenkins
Branch: master

commit 47346f6490d7e5bd397aa28afb96439da5d01d58
Author: Thierry Carrez <email address hidden>
Date: Wed Jan 11 17:26:55 2012 +0100

    Add missing files in tarball

    Fix MANIFEST.in to include all files in released tarballs.
    Note that tools/rfc.sh is ignored since it's only for (deprecated)
    gerrit support. Fixes bug 912193.

    Change-Id: Ic9952220a67d5583e639fcb9e74f472dd9f0fdef

Changed in swift:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-09
Changed in swift:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers