Inconsistencies in endpoint definitions

Bug #1709930 reported by VinceLe on 2017-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Object Storage (swift)
Low
Rajat Sharma

Bug Description

This is a doc bug, not specifically tied to swift, nor cinder BTW...

-----------------------------------
Release: 2.13.1.dev15 on 2017-05-30 23:58
SHA: 72ed8f23a78f11e1ca1688ba086590bb7062a8c7
Source: https://git.openstack.org/cgit/openstack/swift/tree/install-guide/source/controller-install-rdo.rst
URL: https://docs.openstack.org/project-install-guide/object-storage/ocata/controller-install-rdo.html
-----------------------------------

There are discrepancies (I think) about the usage of "tenant" vs "project" in the endpoint creation examples.

Here "%(project_id)s" is used:
-----------------------------------
https://docs.openstack.org/ocata/install-guide-rdo/cinder-controller-install.html

4. Create the Block Storage service API endpoints:

$ openstack endpoint create --region RegionOne \
  volumev2 public http://controller:8776/v2/%\(project_id\)s
-----------------------------------

Whereas "%(tenant_id)s" is used there:
-----------------------------------
https://docs.openstack.org/project-install-guide/object-storage/ocata/controller-install-rdo.html

3. Create the Object Storage service API endpoints:

$ openstack endpoint create --region RegionOne \
  object-store public http://controller:8080/v1/AUTH_%\(tenant_id\)s
-----------------------------------

Maybe this is working, maybe not (I've not tested) but the discrepancy need to be either explained in notes or changed so that all places use the same string sustitution patterns.

I've only looked at those two instances there may be more similar examples...

VinceLe (legoll) on 2017-08-10
description: updated
Matthew Oliver (matt-0) wrote :

So long as keystone still knows what tenant_id is, this works.. and as far as I know it does. But yeah I agree it should probably read project_id as I'm pretty sure tenant_id and project_id are the same thing.. though I could be wrong, unless there is a nuance that I'm not aware of.

I've asked for confirmation in the keystone channel, will update bug when I get a response.

Matthew Oliver (matt-0) wrote :

So I have an update from the Keystone guys.

tenant_id is what it's called in the keystone V2 api and project_id is what it's called in the V3 api.. but they are the same thing.

I'm assuming they are interchangeable so long as your keystone server isn't ancient to now speak V3.

So it would be nice to update the references to tenant_id but make a note that in V2 it was tenant_id and so is also supported.

So yeah, this would be nice to change as it seems to be confusing, so will confirm it, but will keep it as a wishlist or low hanging fruit unless it really becomes an issue for someone.

Changed in swift:
importance: Undecided → Low
status: New → Confirmed
Matthew Oliver (matt-0) on 2017-08-14
tags: added: low-hanging-fruit
Rajat Sharma (tajar29) on 2017-08-16
Changed in swift:
assignee: nobody → Rajat Sharma (tajar29)
Rajat Sharma (tajar29) on 2017-08-16
Changed in swift:
status: Confirmed → In Progress
VinceLe (legoll) wrote :

That proposed fix does not address Matthew's comment about v2 API...

Reviewed: https://review.openstack.org/494144
Committed: https://git.openstack.org/cgit/openstack/swift/commit/?id=ca56090ba101195b5aff189e56b01ef6ffca8915
Submitter: Jenkins
Branch: master

commit ca56090ba101195b5aff189e56b01ef6ffca8915
Author: rajat29 <email address hidden>
Date: Wed Aug 16 14:55:58 2017 +0530

    Inconsistencies in endpoint definitions

    Change-Id: Ie3feea8ed31bfeb9a1047995efc44424071f8224
    Closes-Bug: #1709930

Changed in swift:
status: In Progress → Fix Released

This issue was fixed in the openstack/swift 2.15.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers