Perform a GET and get http/ 1.1 503 Internal Server Error

Bug #1199928 reported by jimmy on 2013-07-10

This bug report was converted into a question: question #232226: Perform a GET and get http/ 1.1 503 Internal Server Error.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Object Storage (swift)
Undecided
Unassigned

Bug Description

Hello,

I just setup swift env in my lab for testing. When i perform <curl -v -H 'X-Auth-Token: AUTH_tkadaffa35a3b4458f96a95c4377c3e496' http://127.0.0.1:8080/v1/AUTH_admin> and I am getting http/1.1 503 Internal Server Error. Can someone please help me with this?

[root@cleverloadgen11 swift]# curl -v -H 'X-Auth-Token: AUTH_tkadaffa35a3b4458f96a95c4377c3e496' http://127.0.0.1:8080/v1/AUTH_admin
* About to connect() to 127.0.0.1 port 8080 (#0)
* Trying 127.0.0.1... connected
* Connected to 127.0.0.1 (127.0.0.1) port 8080 (#0)
> GET /v1/AUTH_admin HTTP/1.1
> User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.13.1.0 zlib/1.2.3 libidn/1.18 libssh2/1.2.2
> Host: 127.0.0.1:8080
> Accept: */*
> X-Auth-Token: AUTH_tkadaffa35a3b4458f96a95c4377c3e496
>
< HTTP/1.1 503 Internal Server Error
< Content-Type: text/html; charset=UTF-8
< Content-Length: 0
< Date: Wed, 10 Jul 2013 17:59:03 GMT
<
* Connection #0 to host 127.0.0.1 left intact
* Closing connection #0
[root@cleverloadgen11 swift]#

Thank,
Jimmy

jimmy (jlu) wrote :

I am not using keystone for auth and I am using tempauth. When I look at the log, I see this error.

Jul 10 15:57:30 cleverloadgen11 proxy-server Account GET returning 503 for [] (txn: txabca432bb0f2402a85d3aebc6d5bc98e) (client_ip: 127.0.0.1)

Kun Huang (academicgareth) wrote :

There may be some config error during deployment, but bugs

Changed in swift:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions