transifex-ify all current OpenStack projects

Bug #1082805 reported by Monty Taylor on 2012-11-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ceilometer
Low
Lianhao Lu
Cinder
Low
Mark McLoughlin
Glance
Low
Mark McLoughlin
Keystone
Undecided
olaph
OpenStack Compute (nova)
Medium
Monty Taylor
OpenStack Core Infrastructure
In Progress
Medium
Andreas Jaeger
OpenStack Dashboard (Horizon)
Medium
Akihiro Motoki
OpenStack Object Storage (swift)
Low
Andreas Jaeger
heat
Medium
Clint Byrum

Bug Description

All of the current OpenStack projects need to have the transifex infrastructure and automation added to them.

Changed in nova:
status: New → Confirmed
importance: Undecided → Medium
Joseph Heck (heckj) wrote :

Russell - what's this mean/intent? Can you link to an etherpad or blueprint describing what needs to be done?

Changed in keystone:
status: New → Triaged
Chuck Thier (cthier) on 2012-12-04
Changed in swift:
importance: Undecided → Low
Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
importance: Undecided → Medium
milestone: none → grizzly-2
status: New → Confirmed
Nick Barcet (nijaba) on 2012-12-28
Changed in ceilometer:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Lianhao Lu (lianhao-lu)

Reviewed: https://review.openstack.org/17930
Committed: http://github.com/openstack/ceilometer/commit/baad3c800f078ef4af994d553eaec869dacad610
Submitter: Jenkins
Branch: master

commit baad3c800f078ef4af994d553eaec869dacad610
Author: Lianhao Lu <email address hidden>
Date: Wed Dec 12 20:13:34 2012 +0800

    Ground work for transifex-ify ceilometer.

    Following http://wiki.openstack.org/Translations to integrate transifex
    translation into ceilometer and to fix bug 1082805.

    This is the ground work to enable translation jobs using transifex and
    Jenkin's in ceilometer. We added the empty file
    ceilometer/locale/ceilometer.pot to avoid the failure of the Jenkin'
    translation-jobs because git doesn't allow empty directory to be added
    into the repository.

    We still need to do the following things once this patch gets accepted:

    1. Make the transifex ceilometer project
    (https://www.transifex.com/projects/p/ceilometer/) as part of the
    openstack transifex project hub and give access to the transifex
    openstack Jenkins account.

    2. Add the translation-jobs into openstack/openstack-ci-puppet for
    ceilometer.

    3. Recheck and/or clean the LOG.foobar strings in ceilometer so that
    only the useful and necessary strings would be extracted into the .pot
    file.

    NOTE:
    1. Don't use '_' as the variable name for "don't care", since it clashes
    with gettext module.

    2. Wrap the string with the underscore function to make it ready for
    translation, e.g.

      internationalized_string = _("I'm internationalized!")
      LOG.debug(_('I speak the language of %(language)s'), locals())

    Change-Id: I9732e424b374afa8f0650baf4e3537109e7520d1

Changed in ceilometer:
status: Confirmed → Fix Committed
olaph (zxkuqyb) on 2013-01-01
Changed in keystone:
assignee: nobody → =w= (zxkuqyb)
olaph (zxkuqyb) on 2013-01-02
Changed in keystone:
status: Triaged → Fix Committed
Chuck Short (zulcss) wrote :

This looks like its already been done for cinder

Changed in cinder:
status: New → Fix Committed
Changed in horizon:
milestone: grizzly-2 → grizzly-3
Thierry Carrez (ttx) on 2013-01-09
Changed in keystone:
milestone: none → grizzly-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-01-09
Changed in ceilometer:
milestone: none → grizzly-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-01-09
Changed in cinder:
milestone: none → grizzly-2
status: Fix Committed → Fix Released
Steven Dake (sdake) on 2013-01-11
Changed in heat:
importance: Undecided → Medium
Steven Dake (sdake) on 2013-01-11
Changed in heat:
status: New → Confirmed
Changed in heat:
assignee: nobody → Clint Byrum (clint-fewbar)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/20094
Committed: http://github.com/openstack/heat/commit/438f6d85ff6de37f84bec332ab5aa5f67c0350a4
Submitter: Jenkins
Branch: master

commit 438f6d85ff6de37f84bec332ab5aa5f67c0350a4
Author: Clint Byrum <email address hidden>
Date: Sat Jan 19 20:45:17 2013 -0800

    Initial support for Transifex translations

    Adds initial message extract and configuration to allow heat
    to work with Transifex, which is the chosen platform for
    translations in OpenStack.

    Fixes bug #1082805

    Change-Id: If8585812d6127948f75994765d274da1629069a3

Changed in heat:
status: In Progress → Fix Committed
Changed in horizon:
milestone: grizzly-3 → none
Thierry Carrez (ttx) on 2013-02-21
Changed in heat:
milestone: none → grizzly-3
status: Fix Committed → Fix Released
Changed in glance:
importance: Undecided → Low
status: New → Triaged
Mark McLoughlin (markmc) wrote :

Seems to be working just fine for Nova

https://jenkins.openstack.org//job/nova-propose-translation-update/lastBuild/consoleText

  + git commit -F-
  [detached HEAD f90f84d] Imported Translations from Transifex
   1 file changed, 186 insertions(+), 185 deletions(-)
  + git review -t transifex/translations

https://jenkins.openstack.org/job/nova-upstream-translation-update/2252/consoleText

  + tx --debug --traceback push -s
  ...
  Pushing translations for resource nova.nova-translations:

Changed in nova:
status: Confirmed → Fix Released
assignee: nobody → Monty Taylor (mordred)
Thierry Carrez (ttx) on 2013-04-04
Changed in keystone:
milestone: grizzly-2 → 2013.1
Thierry Carrez (ttx) on 2013-04-04
Changed in cinder:
milestone: grizzly-2 → 2013.1
Thierry Carrez (ttx) on 2013-04-04
Changed in ceilometer:
milestone: grizzly-2 → 2013.1
Thierry Carrez (ttx) on 2013-04-04
Changed in heat:
milestone: grizzly-3 → 2013.1
Mark McLoughlin (markmc) wrote :
Changed in glance:
status: Triaged → In Progress
assignee: nobody → Mark McLoughlin (markmc)
Mark McLoughlin (markmc) on 2013-05-08
Changed in glance:
status: In Progress → Fix Released
Mark McLoughlin (markmc) wrote :

Looks like translation jobs aren't set up for cinder

Changed in cinder:
importance: Undecided → Low
assignee: nobody → Mark McLoughlin (markmc)
milestone: 2013.1 → none
Akihiro Motoki (amotoki) wrote :

Horizon Transifex automated job is almost complete. Thanks Andreas.
The remaining work is to automate translation imports for master branch.
The script is under review in -infra: https://review.openstack.org/#/c/82176/

I will take care of the progress as Horizon and I18N team.

Changed in horizon:
assignee: Gabriel Hurley (gabriel-hurley) → Akihiro Motoki (amotoki)
status: Confirmed → Triaged
status: Triaged → In Progress
Andreas Jaeger (jaegerandi) wrote :

This is done now for Horizon.

Andreas Jaeger (jaegerandi) wrote :

Patch for swift:
https://review.openstack.org/97092

Patch for infra to have the scripts working:
https://review.openstack.org/98238

Changed in swift:
assignee: nobody → Andreas Jaeger (jaegerandi)
status: New → In Progress
Changed in horizon:
status: In Progress → Fix Released
Andreas Jaeger (jaegerandi) wrote :

Horizon still needs this patch:
https://review.openstack.org/96132

Fix proposed to branch: master
Review: https://review.openstack.org/119454

Changed in openstack-ci:
assignee: olaph (zxkuqyb) → Andreas Jaeger (jaegerandi)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/97092
Committed: https://git.openstack.org/cgit/openstack/swift/commit/?id=7a192987c0a5edb9e239ffb4aba3b1dac083b41e
Submitter: Jenkins
Branch: master

commit 7a192987c0a5edb9e239ffb4aba3b1dac083b41e
Author: Andreas Jaeger <email address hidden>
Date: Sun Jun 1 11:51:29 2014 +0200

    Setup localization properly

    To start translation of swift, we need to initially import the
    translation file - and place it at the proper place so that
    the usual CI scripts can handle it.

    The proper place is for all python projects
    $PROJECT/locale/$PROJECT.pot, so move locale/$PROJECT.pot to the new
    location and regenerate the file.

    Update setup.cfg with the new paths.

    Further imports will be done by the OpenStack Proposal bot.

    Change-Id: Ide4da91f2af71db529f4a06d6b1e30ba79883506
    Partial-Bug: #608725
    Closes-Bug: #1082805

Changed in swift:
status: In Progress → Fix Committed
Download full text (21.0 KiB)

Reviewed: https://review.openstack.org/122541
Committed: https://git.openstack.org/cgit/openstack/swift/commit/?id=18901494e9b4b47fb181a5ead8ed82738db8563f
Submitter: Jenkins
Branch: feature/ec

commit fc5cee5f05692f7e6dd5ad5a6d0ae682dd4bf3e0
Author: Christian Schwede <email address hidden>
Date: Mon Sep 15 17:22:54 2014 +0000

    Allow filtering by region in swift-recon

    The option "-r" is already used, thus only "--region" is used to specify
    filter by region.

    Change-Id: If769f2f3191c202933b03b48fe0f22b7c94a4dd6
    Closes-Bug: 1369583

commit 423ac74e888dcd693129100e0b37a51428bb62e1
Author: Christian Schwede <email address hidden>
Date: Sun Sep 14 23:41:19 2014 +0200

    Fix internal link to keystoneauth in documentation

    This patch fixes a broken link at the end of the table in
    http://docs.openstack.org/developer/swift/logs.html#swift-source

    Change-Id: I989173ac93e0f840997333be0d5cec07eb77b304

commit 64548420c87f3163ed543c9e9a02a4f1abec69e0
Author: Andreas Jaeger <email address hidden>
Date: Sat Sep 13 09:48:14 2014 +0200

    Stop using intersphinx

    Remove intersphinx from the docs build as it triggers network calls that
    occasionally fail, and we don't really use intersphinx (links other
    sphinx documents out on the internet)

    This also removes the requirement for internet access during docs build.

    This can cause docs jobs to fail if the project errors out on
    warnings.

    Change-Id: I71e941e2a639641a662a163c682eb86d51de42fb
    Related-Bug: #1368910

commit 5c9835125802c51e2eb2823f5208d53c358a5e84
Author: Christian Schwede <email address hidden>
Date: Fri Sep 12 14:37:04 2014 +0000

    Fix RingBuilder._build_max_replicas_by_tier docstring

    The current docstring doesn't include zones, and the order of the
    entries is not up to date with the current code. Let's fix this.

    Change-Id: Ibabd79427b83d9e8c86b2caeb93dee219c8274c0

commit a03732e142540e5a7d6cb11de5232f0642beb20d
Author: Alistair Coles <email address hidden>
Date: Fri Sep 12 10:20:19 2014 +0100

    Add comments to clarify change to www-authenticate test

    Trivial patch to tidy-up change to the functional test for
    www-authenticate header and add a comment to explain
    that multiple header values might be returned.

    Change-Id: If62cb3fd9e11450a2be0cec71e80ecb74a959d04
    Related-bug: 1368048

commit ab96796dc8d1da9037330da0822c8b8d2264d192
Author: Alistair Coles <email address hidden>
Date: Thu Sep 11 10:23:32 2014 +0100

    Fix broken www-authenticate functional test

    testQuotedWWWAuthenticateHeader functional test started failing
    due to a change to keystonemiddleware.auth_token, which now adds
    its own www-authenticate header in addition to the one that swift
    keystoneauth adds.

    This patch changes the functional test to check expected
    swift generated header value is in the concatenation of
    www-authenticate values.

    Verified that functional tests still pass using tempauth.

    Closes-Bug: 1368048
    Change-Id: I913af077df800a559d259c1622f286ad10eae9df

commit f4d3facdf...

Thierry Carrez (ttx) on 2014-10-06
Changed in swift:
milestone: none → 2.2.0-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-10-16
Changed in swift:
milestone: 2.2.0-rc1 → 2.2.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers