Make short URLs using various sites

-t/--url option not working with tr.im

Reported by Ahmed El-Mahdawy on 2009-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
surl
Medium
Ahmed El-Mahdawy

Bug Description

Using the -t or --url option with tr.im queries the API, but returns the same URL back:

propeng@propeng:~/Projects/Python/surl$ ./surl.py -t http://www.google.com -s tr.im
http://www.google.com

while the following returns a correct URL:

propeng@propeng:~/Projects/Python/surl$ echo "http://www.google.com" | ./surl.py -s tr.im
http://tr.im/DGWb

Changed in surl:
assignee: nobody → Propeng (aa-mahdawy)
status: New → In Progress
Ahmed El-Mahdawy (propeng) wrote :

This is not caused by using --url instead of -t, due to a duplicate argument for --url and --title. A fix will be now commited.

Changed in surl:
status: In Progress → Fix Committed
Savvas Radevic (medigeek) wrote :

released in 0.6!

Changed in surl:
importance: Undecided → Medium
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers