Superkb fails to start in startup

Bug #627990 reported by marcosvega on 2010-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Superkb
Medium
Octavio Alvarez
Ubuntu
Undecided
Unassigned

Bug Description

I'm running Ubuntu Lucid.

I added Supperkb to start in startup, but every startup I have to do the keyboard troubleshoot in GNOME. After that it works fine, but it's kind of annoying to do this every startup.

Regards

Octavio Alvarez (alvarezp) wrote :

> but every startup I have to do the keyboard troubleshoot in GNOME.

Do you mean, the "add and remove a layout" procedure?

marcosvega (pinguino-40-2) wrote :

>Do you mean, the "add and remove a layout" procedure?

Yes, after I do the add and remove layout, Superkb works fine.

Octavio Alvarez (alvarezp) wrote :

I think I know where the problem lies but I'd still like to ask you to paste the output of superkb when it fails (before applying "the procedure").

marcosvega (pinguino-40-2) wrote :

This is the output:

superkb 0.21: Welcome. This program is under development.

It's strongly recommended to set the following on xorg.conf:

| Section "ServerFlags"
| Option "AllowDeactivateGrabs" "On"
| Option "AllowClosedownGrabs" "On"
| EndSection

With these, if the program fails while drawing the keyboard, you will be able
to kill it by pressing Ctrl-Alt-*, and restore Autorepeat with 'xset r on'.

superkb: Could not load keyboard geometry information. Quitting.

If using GNOME you might want to try adding akeyboard layout and then
removing it, and making sure yourdefault layout is effectively selected as
default.

Every startup is the same.

Octavio Alvarez (alvarezp) wrote :

This is a tough one. Try the following workaround (taken from the mailing list):

<blockquote>
Try issuing the following command in a terminal window (not as root):

setxkbmap -geometry 'pc(pc104)' #Notice the single quotes!

You need to issue killall superkb and run it again to make it
see the change.

Once you make it work, fix the setting according to your
distribution instructions before loading Superkb. This is usually
done in /etc/X11/xorg.conf as stated in
http://www.x.org/releases/X11R7.5/doc/input/XKB-Config.html and
remember that "setxkbmap -print" is your friend.

</blockquote>

Changed in superkb:
importance: Undecided → Medium
assignee: nobody → Octavio Alvarez (alvarezp)
status: New → Confirmed
marcosvega (pinguino-40-2) wrote :

Sorry for the late answer.
Running the line:
setxkbmap -geometry 'pc(pc104)'
Works great, but I don't have any xorg.conf, I think I just have to do a script so every startup the command above gets execute before superkb, or there is another way?

Octavio Alvarez (alvarezp) wrote :

If you start X by calling startx you might want to try $HOME/.xinitrc (note the dot before xinitrc).

If you start X by logging in using GDM or any other display manager (the simple graphical login screen) you might want to try $HOME/.xsession (also, dot-xsession). This one I have not tested yet myself.

Both files should have the eXecute bit set (chmod +x $HOME/.whatever)

Make sure the script is actually being run: use something like "touch file" inside the script and check if "file" gets created when starting your session.

This should allow you to execute any command right after X or the DE has been initialized.

If this doesn't work, please report it here. I'm thinking on a way to add a delay to Superkb initalization if getting keybord geometry fails and retry. I'd rather not do this because this actually looks more like a bug in GNOME.

Octavio Alvarez (alvarezp) wrote :

Hello! I would like to know if this fixed your problem, if it worked around it, if did not work at all or if it has not been tested. Thanks!

marcosvega (pinguino-40-2) wrote :

I'm so sorry for the late response but I was very busy and also forgot to post about this issue. First, I didn't have .xinitrc neither .xsession in my home folder, but I created an script (as I said above) that executes first the setxkbmap and then superkb and add it to the startup programs in System>Preferences>Startup Applications and it worked.

Then I bought another laptop and I installed it Ubuntu 10.10 and Superkb runs fine. It seems the issue about the keyboard is GNOME in Ubuntu 10.04. Because in previous versions of Ubuntu, Superkb in the same laptop used to work fine.

Thank you very much for your help.

PS. I attach the script, even I think it is obvious.

Jesus Godinez (jesusarmando) wrote :

Sometimes selecting a Keyboard model works form me.

IKT (ikt) on 2011-05-13
Changed in ubuntu:
status: New → Invalid
IKT (ikt) on 2011-05-13
Changed in ubuntu:
status: Invalid → New
Shimi Chen (shimi-chen) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!

If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:

1. http://www.ubuntu.com/project/about-ubuntu/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories

Changed in ubuntu:
status: New → Invalid
Octavio Alvarez (alvarezp) wrote :

The message from Shimi Chen only affects the "Ubuntu" component.

The bug itself is *NOT* marked at invalid. It is still marked as confirmed.

Octavio Alvarez (alvarezp) wrote :

Hi.

I would like to know if this bug still happens. It hasn't occurred anymore to me and appears to be an X.org bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers