Sun Java SE Development Kit

[Package Request] sun-java6-plugin on AMD64?

Reported by Michael B. Trausch on 2007-04-08
58
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Sun Java
Invalid
Undecided
Unassigned
sun-java6 (Debian)
Invalid
Undecided
Unassigned
sun-java6 (Ubuntu)
Low
Matthias Klose

Bug Description

It seems the rest of sun-java6 is installed on my system:

mbt@sage:~$ dpkg -l|grep java6
ii sun-java6-bin 6-00-2ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (architecture d
ii sun-java6-demo 6-00-2ubuntu2 Sun Java(TM) Development Kit (JDK) 6 demos and examples
ii sun-java6-fonts 6-00-2ubuntu2 Lucida TrueType fonts (from the Sun JRE)
ii sun-java6-jdk 6-00-2ubuntu2 Sun Java(TM) Development Kit (JDK) 6
ii sun-java6-jre 6-00-2ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (architecture i
mbt@sage:~$

I can run Java software (e.g., “java -jar file.jar”), but I cannot install the browser plugin, because it does not seem to exist:

mbt@sage:~/Downloads$ sudo apt-get install sun-java6-plugin
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package sun-java6-plugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package sun-java6-plugin has no installation candidate
mbt@sage:~/Downloads$

Is there any possibility of that being fixed?

Matthias Klose (doko) wrote :

confirmed; the plugin is provided for i386 only by Sun.

Changed in sun-java6:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Charles (nightwatch2006) wrote :

Is there any other distro with plugin for 64 bits arch?
I think it's should me assigned as important due we cannot use java applications in the browser.

André Klitzing (misery) wrote :

Maybe it will be in Java 1.7

---
This RFE has fianaly been comitted to the dolphin (JDK 1.7) release.
Posted Date : 2007-01-16 22:20:04.0
---

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4802695

Changed in sun-java:
status: Unknown → Confirmed
Matthias Klose (doko) wrote :

won't be fixed by upstream in sun-java6

Changed in sun-java6:
assignee: nobody → doko
status: Confirmed → Won't Fix
Changed in sun-java6:
status: Unknown → Confirmed
James Stansell (jamesstansell) wrote :

Sun's bug 4802695 (link above) is currently RFE #1 on the JDC:

Note that a possible interim workaround is the gcjwebplugin, although it is not yet recommended for general use. It sounds, though, like the icedtea project could change that, likely before Java 7 is released.

-james.

André Klitzing (misery) wrote :

by the way... since gutsy there is the package "icedtea-java7" that has a java-plugin for amd64.

https://launchpad.net/ubuntu/+source/icedtea-java7
http://en.wikipedia.org/wiki/IcedTea

Changed in sun-java:
status: Confirmed → Unknown
Changed in sun-java:
status: Unknown → Confirmed
mabovo (mabovo) wrote :

Problem is that icedtea-java7 is not completely developed and doesn't work on jvm applets like home banking or in certain e-commerce websites.
Someone like me may feel like a second class "hardy" citzen not having sun-java6-plugin available for amd64 machines.

Evgeny Kuznetsov (nekr0z) wrote :

It was somehow possible to install Sun Java browser plugin onto 7.10 without tinkering with chroot'ed environment (I know the plugin was actually 32-bit, but it was easily accessible on 64-bit systems). Is it entirely impossible to provide a similar solution for Hardy?

Bruce Cowan (bruce89) wrote :

This is no longer a problem in Hardy, OpenJDK has a plugin for all architectures.

Evgeny Kuznetsov (nekr0z) wrote :

Bruce, if you mean icedtea-java7-plugin, then it's definitely NOT a solution, since it doesn't support a whole lot of java-based applets on websites. If there is supposed to be something like openjdk-plugin, then I must say I cannot see it in repositories.

Bruce Cowan (bruce89) wrote :

I mean icedtea-gcjwebplugin. It's better than nothing, and seems to work well.

Evgeny Kuznetsov (nekr0z) wrote :

Well, it certainly is better than nothing, but it is nothing close to Sun's Java. A lot of sites display grey rectangle where java applet should be with this plugin. Why not provide a workaround with Sun's Java, as it was done in Gutsy?

Graeme (unit3) wrote :

I agree. Java support is basically too broken for normal users on hardy/amd64 at the moment. Until icedtea can run the bulk of web applets, it is not an appropriate replacement for the 32-bit wrapper that existed in Gutsy.

J.D. (yamokosk) wrote :

Sorry to be impatient on this but where are we at on this? Waiting for Sun?

This is a HUGE problem for me... this isn't "I can't play my party poker or check my bills online." This makes my Ubuntu box completely worthless. I am at a facility that uses a Cisco Java applet to authenticate users on the network... no java plugin for my browser, no Cisco applet, no login to web -> dead box.

In an era where the Internet is so important, I think its gateways (browsers) and their associated functionality should demand the highest priority from distro authorities. So much so that I would even vote to take amd64 support out of Ubuntu *until* things like this are fixed. At the very least take the amd64 download off the main downloads page. Granted.. I know I am probably a very small minority of the users but as it stands, i have no use for my box right now. Will have to fall back to 32 bit version until this is fixed.

Steve Gates Junior (dr0zaxx) wrote :

dell@dell-laptop:~$ dpkg -l | grep "java"
ii java-common 0.28ubuntu3 Base of all Java packages
ii sun-java6-bin 6-06-0ubuntu1 Sun Java(TM) Runtime Environment (JRE) 6 (architecture dependent
ii sun-java6-jre 6-06-0ubuntu1 Sun Java(TM) Runtime Environment (JRE) 6 (architecture independe
dell@dell-laptop:~$

Java applets are broken on FF 3.0 even with the runtimes installed.

Richard Elkins (texadactyl) wrote :

JD, you might not have to wait for Java 1.7 if you are willing to take a chance on a beta. See Build b28 at http://download.java.net/jdk6/. They seem to have covered AMD64 in beta. Unfortunately for me, I have an Intel X64 but I might try it anyways for laughs.

The un-paid OpenJDK folks are working hard to come up with a stable and accurate clone of Sun's JRE and Plugin. Having put my own time into open source projects, I can sympathize with them. Not being commercial, they have limited testing resources -or- you could say that we are their testing resources.

On the other hand, I know that it is frustrating to wait when you are trying to be commercial-free ... as much as possible. I remember that the 32-bit Sun Java plugin install into the 32-bit Firefox browser was well-integrated in Ubuntu 7.10....just as automated as in Windows although in a different way (E.g. Synaptic). That was a super job and easy to document/explain.

Unfortunately, icedtea-gcjwebplugin doesn't work 100% yet as a number of folks have pointed out. E.g. Try a game at http://www.pogo.com.

Things could be worse. I could be at work today using Windoze, OutLuck, and Internet Exploder.

-Richard

Graeme (unit3) wrote :

Richard: thanks for the link to the 1.7 beta stuff. Keep in mind that Intel x64 is binary compatible (the same instruction set) as AMD64, so you should be able to test the new release on your Intel system without problems. The builds are generally called "amd64" on Linux simply because AMD invented the new 64 bit instructions, and Intel copied them later, not to denote a chip specific build.

In any case, does anyone know if there are any Debian or Ubuntu packages available for this new Java beta?

Juan Izquierdo (jemilioi) wrote :

I wanted to install Sun Java on my computer for Ubuntu, so i opened the terminal and put:
sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
and the package started installing but when it came down to Sun Operating System Distributor License for Java, i clicked Enter but it wouldn't do so.
How can i make it go to the next step when it wont respond to the key "enter"?

James Stansell (jamesstansell) wrote :

Just to be clear: the 6u12 download is still an 'early access' version. The actual release is expected next February. By all means download it and test it out if you don't mind being a guinea pig. Just realize that it's not generally available yet.

Savvas Radevic (medigeek) wrote :

Re-opening the bug to "New" for sun-java6 on Ubuntu, taking into consideration that upstream will provide a 64-bit plugin.

I also think that the launchpad sun-java project should be tracked using: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4802695
..and not: https://jdk-distros.dev.java.net/issues/show_bug.cgi?id=13

Changed in sun-java6:
status: Won't Fix → New
Matthias Klose (doko) wrote :

fixed in jaunty

Changed in sun-java6:
status: New → Fix Released
Daniel Letzeisen (dtl131) wrote :

I'm using Jaunty64 Alpha 3 and the version of java6 in the repo is still 6u11, and doesn't include libnpjp2.so for amd64. Will Java 6u12 definitely be included in Jaunty, even if Sun releases it in late February (after the initial feature freeze)?

Scott Moser (smoser) wrote :

there is now a official 6u12 release at
http://java.sun.com/javase/downloads/index.jsp . That link is surely time-sensitive, but the point is that the official release is out. It'd be great if that made it to jaunty.

James Stansell (jamesstansell) wrote :

@Scott, it already is in jaunty.

https://launchpad.net/ubuntu/+source/sun-java6

(BTW, the version from sun that debian/ubuntu requires in order to create a package is described at the https://jdk-distros.dev.java.net/ page. It results in the same binaries as the download you linked to, but is provided with a license that ubuntu can use.)

mbien (mbien) wrote :

will an upgrade to jaunty fix the symlinks pointing to the old plugin or has it only be tested on fresh installations?

Dima Ryazanov (dima-gmail) wrote :

What about Karmic? Why am I still unable to install sun-java6-plugin?

Jesper de Jong (jespdj) wrote :

@Dima: What happens if you try? Do you get an error message, and if so, what is the message?

There is a sun-java6-plugin package for Karmic i386 and also amd64, so it should just work normally on Karmic.

sun-java6-plugin is still not present in Ubuntu 10.04:

Package sun-java6-plugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package sun-java6-plugin has no installation candidate

Daniel Letzeisen (dtl131) wrote :

You have to enable the "partner" repository in SYstem -> Administration -> SOftware SOurces

Screatch (screatch) wrote :

Same problem on Ubuntu 10.10 Maverick beta, partner repository is enabled.

Changed in sun-java:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Changed in sun-java6 (Debian):
importance: Unknown → Undecided
status: Confirmed → New
Daniel Letzeisen (dtl131) wrote :

Marking invalid, since Ubuntu no longer has the license to distribute Sun/Oracle Java:
https://lists.ubuntu.com/archives/ubuntu-security-announce/2012-January/001554.html

Changed in sun-java6 (Debian):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.