Display the time the schedule page was last refreshed

Bug #668528 reported by Chris Johnston
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Summit
Wishlist
Nigel Babu

Bug Description

In local (UDS Event) time

Related branches

Changed in summit:
status: New → Confirmed
Revision history for this message
Nigel Babu (nigelbabu) wrote :

I remember there is a hack to get the local time set up. How does this hack work?

Changed in summit:
status: Confirmed → In Progress
assignee: nobody → Nigel Babu (nigelbabu)
Changed in summit:
importance: Undecided → Wishlist
Joey Stanford (joey)
tags: added: linaro
Revision history for this message
Nigel Babu (nigelbabu) wrote :

I've duped sladen's new bug to this one. Adding in sladen's comments here.

Sometimes a timetable screen gets "stuck" and doesn't update. When this happens it is not possible to know that the display has not been automatically updated.

One possible solution would be to add a pure-Javascript timer that states somewhere visible:

  "Last refresh XX minutes ago"

and have this updated by the page. Should the page fail to update it would be obvious to the viewer that the display might be several tens or hundreds of minutes out-of-date.

I think this is a more practical fix. I'll scape my current fix.

Changed in summit:
status: In Progress → Fix Committed
Changed in summit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints