Summit - The UDS Scheduler

Don't depend on a room being declared "plenary"

Reported by Jorge O. Castro on 2010-09-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Summit
Critical
Unassigned

Bug Description

Right now if you have a room that isn't marked as a plenary room the whole thing breaks.

It shouldn't matter if a room is declared plenary or not.

Related branches

Dave Walker (davewalker) on 2010-10-23
Changed in summit:
status: New → Confirmed
Jorge O. Castro (jorge) wrote :

Don't worry about this one for UDS-O, but let's fix this for P since this always happens.

Changed in summit:
importance: Undecided → Critical
tags: added: uds-p
Joey Stanford (joey) on 2011-05-23
tags: added: linaro
Nigel Babu (nigelbabu) wrote :

I just realized what was going on here. ./manage.py init-slots, automatically creates a plenary slot. Now when you do have a plenary slot, but no plenary room, it breaks. I think we can catch that breaking and report an error, but otherwise, its fine, really.

Changed in summit:
status: Confirmed → Incomplete
Changed in summit:
status: Incomplete → Fix Committed
James Westby (james-w) on 2011-09-15
Changed in summit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers