Clicking on star should allow me to set attending through ajax form

Bug #1066345 reported by Monty Taylor on 2012-10-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Summit
Wishlist
José Antonio Rey

Bug Description

It would be nice if clicking on the star on the agenda page ajax'ed the user as attending instead of opening up a new page.

Related branches

José Antonio Rey (jose) on 2012-10-13
Changed in summit:
status: New → Confirmed
Chris Johnston (cjohnston) wrote :

If you click on the star, it does take you to a page which allows you to set yourself as attending.

Changed in summit:
status: Confirmed → Invalid
Chris Johnston (cjohnston) wrote :

The only issue with doing it this way is that you don't get to set your 'level of attendance', it will default you to the lowest level.

Changed in summit:
status: Invalid → Triaged
importance: Undecided → Wishlist
description: updated
Monty Taylor (mordred) wrote :

Yeah - so, the bug is that when I'm going through all of the possible sessions, clicking on the star to take me to the page with the two different status choices, and then from there through to the main page for the session is a very heavy workflow.

On the other hand, taking this page's Status field as an example of a control that could do the other thing - if, when I clicked on the star, a 3-choice menu popped up listing:

Attending
Want to Attend
Not Attending

And when I clicked on one of them it set my attendence status, then I would be able to zip through the schedule in a way more efficient manner.

Chris Johnston (cjohnston) wrote :

This would be a handy feature... I also made a suggestion on a way to make it a little better... I'm on holiday so I don't know if it will be done before UDS, however, my suggestion would make the work flow a little better, I think, if noone gets a chance to do the ajax stuff..

My suggestion was similar to how http://bazaar.launchpad.net/~summit-hackers/summit/trunk/view/head:/summit/schedule/views.py#L416 is done, where you click the star your marked attending, but you don't leave the page your on. It does make it less usable than the ajax suggestion, however, it gets it closer to where it should be I think.. Hopefully someone will get a chance to do it before UDS.

summary: - Clicking on star should add me to session
+ Clicking on star should allow me to set attending through ajax form
José Antonio Rey (jose) on 2012-10-15
Changed in summit:
assignee: nobody → José Antonio Rey (joseeantonior)
status: Triaged → In Progress
José Antonio Rey (jose) wrote :

Did it via HTML, but it redirects to the meeting page once it's set as attending. This is a temporary solution as UDS is close, and the refresh instead of redirecting function should be reported as a new bug if the current MP gets approved.

José Antonio Rey (jose) wrote :

Will be working on an AJAX'ed fix after UDS/Connect.

Matthew Wedgwood (mew) wrote :

It's been nearly a year since the last activity on this one. The workflow for registering for sessions is pretty tedious, particularly since UDS now is online and we don't have the need for a waitlist.

What I would expect to happen (one or two clicks per signup):
1. Display a schedule such as by-day or by-track.
2. For each session I'd like to attend, click the star icon. The session would be added to my schedule with no additional interaction needed. AJAX-style.

What does happen (seven to eight clicks per signup):
1. Display a schedule such as by-day or by-track.
2. For each session I'd like to attend, I click the star icon
3. I'm presented a new page presenting two seemingly equivalent options - whether I'm attending or would like to attend. Via a drop-down menu, requiring two clicks to make a selection.
4. I select one of those options and click Save
5. I'm taken to the page for the session
6. I either 1) Click "back" twice then reload to see the change on the schedule page or 2) navigate back to the schedule via the top nav.

Even if there is still a need for the "Very interested in attending" option, it could be presented as a javascript menu on the schedule when the star is clicked (still only two to three clicks per signup).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers