FTBFS with Python 3.3: tests fail

Bug #1025392 reported by Jelmer Vernooij on 2012-07-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
subunit
High
Robert Collins
subunit (Ubuntu)
High
Unassigned

Bug Description

  affects subunit

(as reported against the Debian package)

On Mon, Jul 16, 2012 at 06:11:22PM +0200, Jakub Wilk wrote:
> subunit FTBFS if built against Python 3.3:
> | ======================================================================
> | FAIL: test_add_error_details (subunit.tests.test_test_protocol.TestTestProtocolClient)
> | Test stopTest on a TestProtocolClient with details.
> | ----------------------------------------------------------------------
> | Traceback (most recent call last):
> | File "/build/subunit-2Qh_CJ/subunit-0.0.8+bzr176/python/subunit/tests/test_test_protocol.py", line 1213, in test_add_error_details
> | "]\n") % self.test.id()))
> | AssertionError: b'error: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;language=python,charset=utf8\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n' != b'error: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;charset=utf8,language=python\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n'
> |
> | ======================================================================
> | FAIL: test_add_expected_failure_details (subunit.tests.test_test_protocol.TestTestProtocolClient)
> | Test addExpectedFailure on a TestProtocolClient with details.
> | ----------------------------------------------------------------------
> | Traceback (most recent call last):
> | File "/build/subunit-2Qh_CJ/subunit-0.0.8+bzr176/python/subunit/tests/test_test_protocol.py", line 1237, in test_add_expected_failure_details
> | "]\n") % self.test.id()))
> | AssertionError: b'xfail: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;language=python,charset=utf8\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n' != b'xfail: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;charset=utf8,language=python\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n'
> |
> | ======================================================================
> | FAIL: test_add_failure_details (subunit.tests.test_test_protocol.TestTestProtocolClient)
> | Test addFailure on a TestProtocolClient with details.
> | ----------------------------------------------------------------------
> | Traceback (most recent call last):
> | File "/build/subunit-2Qh_CJ/subunit-0.0.8+bzr176/python/subunit/tests/test_test_protocol.py", line 1189, in test_add_failure_details
> | "]\n") % self.test.id()))
> | AssertionError: b'failure: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;language=python,charset=utf8\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n' != b'failure: subunit.tests.test_test_protocol.TestTestProtocolClient.test_start_test [ multipart\nContent-Type: text/plain\nsomething\nF\r\nserialised\nform0\r\nContent-Type: text/x-traceback;charset=utf8,language=python\ntraceback\n34\r\ntesttools.testresult.real._StringException: boo qux\n0\r\n]\n'
> |
> | ----------------------------------------------------------------------
> | Ran 266 tests in 0.685s
> |
> | FAILED (failures=3)
> | FAIL: runtests.py

Related branches

Matthias Klose (doko) wrote :

looks like the tests pass on amd64, but fail on any 32bit platform

Changed in subunit (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-13.04-beta-1
status: New → Confirmed
tags: added: ftbfs

I can reproduce this bug on amd64.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package subunit - 0.0.8+bzr176-1ubuntu2

---------------
subunit (0.0.8+bzr176-1ubuntu2) raring; urgency=low

  * Sort remaining iterators over dictionary keys.
  * Execute python test-suite multiple times with different hash seeds.
 -- Dmitrijs Ledkovs <email address hidden> Wed, 31 Oct 2012 10:21:52 +0100

Changed in subunit (Ubuntu):
status: Confirmed → Fix Released
Jonathan Lange (jml) wrote :

Hey Dmitrijs,

What happened to your merge proposal against subunit for fixing this bug?

lifeless and I were both (independently!) going to reply, suggest a couple of pointers and help you get that merged into trunk. Now we can't find the MP, and thus don't know how to help.

I'd rather Ubuntu didn't carry a patch for this.

cheers,
jml

Jonathan Lange (jml) wrote :

Hey Dmitrijs,

What happened to your merge proposal against subunit for fixing this
bug?

lifeless and I were both (independently!) going to reply, suggest a
couple of pointers and help you get that merged into trunk. Now we can't
find the MP, and thus don't know how to help.

I'd rather Ubuntu didn't carry a patch for this.

cheers,
jml

Changed in subunit:
status: New → Triaged
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

My approach changed implementation (by introducing sorting in the code path), instead sorting/comparison should be done in the tests only. I need to rework the distro patch I uploaded to not have this performance penalty.

Robert Collins (lifeless) wrote :

Tests pass for me with 3.3; marking incomplete pending a test case/reproduction instructions that work.

Changed in subunit:
status: Triaged → Incomplete
Robert Collins (lifeless) wrote :

I had a bad virtualenv; though it was 3.3, was 2.7. Doh.

Changed in subunit:
status: Incomplete → Triaged
Changed in subunit:
assignee: nobody → Robert Collins (lifeless)
milestone: none → next
status: Triaged → Fix Committed
Changed in subunit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers