No longer able to do zFCP/SCSI multipath installations on focal image '20200730.1'

Bug #1889749 reported by Frank Heimes on 2020-07-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Critical
Canonical Foundations Team
subiquity
Critical
Unassigned

Bug Description

I'm following the QA/Tracker requests to test images, hence today I tested the image:
http://cdimage.ubuntu.com/ubuntu-server/focal/daily-live/20200730.1/focal-live-server-s390x.iso
and I noticed that I am no longfer able to do zFCP/SCSI multipath installations.
(I am pretty sure that it still worked with the previous image:
http://cdimage.ubuntu.com/ubuntu-server/focal/daily-live/20200730/focal-live-server-s390x.iso
I may try that later again).

After having the correct HBAs activated in subiquity's zDev screen they are represented there as online.

I can go to the installer shell and can also see all needed zfcp devices active and online:
root@ubuntu-server:/# lszdev --online
TYPE ID ON PERS NAMES
zfcp-host 0.0.f00b yes yes
zfcp-host 0.0.f10b yes yes
zfcp-lun 0.0.f00b:0x50050763060b16b6:0x4026400600000000 yes no sdb sg1
zfcp-lun 0.0.f00b:0x50050763061b16b6:0x4026400600000000 yes no sda sg0
zfcp-lun 0.0.f10b:0x50050763060b16b6:0x4026400600000000 yes no sdd sg3
zfcp-lun 0.0.f10b:0x50050763061b16b6:0x4026400600000000 yes no sdc sg2
qeth 0.0.0600:0.0.0601:0.0.0602 yes no enc600
generic-ccw 0.0.0009 yes no
root@ubuntu-server:/#

But when I proceed to the 'guided storage configuration' I get this message (and obviously can't proceed with the installation):

▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
  Guided storage configuration [ Help ]
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀
  Block probing did not discover any disks. Unfortunately this means that
  installation will not be possible.

Going back to the shell and doing a manual 'probert --storage' seems to work.
Please see the attached file for the lszdev and probert output.

Frank Heimes (fheimes) wrote :
Changed in ubuntu-z-systems:
importance: Undecided → Critical
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1889749

tags: added: iso-testing
Frank Heimes (fheimes) wrote :

I just tried the image '20200730' and it worked.
Hence a regression must have happen while moving from '20200730' to '20200730.1'.

Frank Heimes (fheimes) wrote :

attaching the logs (nothing in /var/crash)

Changed in subiquity:
milestone: none → 20.04.1
importance: Undecided → Critical
Frank Heimes (fheimes) wrote :

Just as a side note running probert manually (where the output looks fine) and restating the installer (reconnecting) doesn't help.

The logs in #1 are from a system that has two FCP devices (so 2 times 4 paths), but it's the same one system with a single one.

Dimitri John Ledkov (xnox) wrote :

There are warnings that probedata is missing blockdev.... but it is there.
I wonder if i'm looking at an old state.

Dimitri John Ledkov (xnox) wrote :

1937 is good
1963 is bad

1937 is currently republished to stable/20200730
1963 is currently published in stable

Dimitri John Ledkov (xnox) wrote :

Refreshing live media to/from 1937 & 1963 reproduces the issue. Guided storage configuration is shown with old subiquity snap & not shown with new one.

So the rest of the ISO must be alright. Something regressed in subiquity snap. Trying to diff the two revisions downloaded with:

UBUNTU_STORE_ARCH=s390x snap download subiquity --channel stable
UBUNTU_STORE_ARCH=s390x snap download subiquity --channel stable/20200730

Doesn't show anything of particular concern.

Dimitri John Ledkov (xnox) wrote :

probert & curtin are unchanged.

Changed in subiquity:
status: New → Fix Committed
Frank Heimes (fheimes) on 2020-07-31
Changed in ubuntu-z-systems:
status: New → Fix Committed
Frank Heimes (fheimes) wrote :

I was able to successfully verify the fixed subiquity 20.07.1+git2.5de9df3e (1969)
Thx

Frank Heimes (fheimes) wrote :

I've just updated my install server with the 20200731 image and can confirm that I was again successfully able to verify zfcp installations on LPAR and z/VM - thx a lot!

Ah it was adding 'multipath' to partitions that did this -- somehow it makes the code that tries to hide all but one of the paths to a given disk go haywire.

Frank Heimes (fheimes) wrote :

Since 20.04.1 is out, I'm changing this ticket (project entry) to Fix Released.

Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Changed in subiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers