raid installs are failing with edge

Bug #1829325 reported by Michael Hudson-Doyle on 2019-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin
Undecided
Michael Hudson-Doyle
subiquity
Critical
Unassigned
mdadm (Ubuntu)
Undecided
Unassigned

Bug Description

Raid installs fail at the "configure mdadm" step. I'm not sure when this started, or whether it's eoan specific (about to test this last part). The raid1 tests are still passing with stable though.

Related branches

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

Happens with a disco based ISO too. It's just a guess but I think it might be the change to bind mount /run that does this?

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

Yeah, if I skip the step that bind mounts /run into /target, RAID works again. Sigh.

Changed in subiquity:
status: New → Triaged
importance: Undecided → Critical
Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

I think this is arguably a curtin bug: it doesn't disable daemons in the target while reconfiguring mdadm. Should be easy enough to test that theory, will report back in a bit.

Revision history for this message
Ryan Harper (raharper) wrote : Re: [Bug 1829325] Re: raid installs are failing with edge

It actually does disable daemons. See ChrootableTarget.

The check in the post script still will exec systemctl commands. Can we get
a debug log of the failure to confirm?

Ryan

On Sun, May 19, 2019 at 17:15 Michael Hudson-Doyle <email address hidden>
wrote:

> I think this is arguably a curtin bug: it doesn't disable daemons in the
> target while reconfiguring mdadm. Should be easy enough to test that
> theory, will report back in a bit.
>
> --
> You received this bug notification because you are subscribed to
> subiquity.
> Matching subscriptions: subiquity-bugs
> https://bugs.launchpad.net/bugs/1829325
>
> Title:
> raid installs are failing with edge
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/subiquity/+bug/1829325/+subscriptions
>

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

It would disable daemons _if it used ChrootableTarget_. MP incoming.

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :
Revision history for this message
Ryan Harper (raharper) wrote :

Let's definitely get the logs.

The restart code in postinst has been around since 2014. So that's unlikely to be the cause, though the presence of /run does trigger something that wasn't ever tested before.

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :
Changed in mdadm (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mdadm - 4.1-2ubuntu2

---------------
mdadm (4.1-2ubuntu2) eoan; urgency=medium

  * Drop broken and unused init scripts in favor of native systemd units,
    which can cause failure to reconfigure mdadm package under certain
    confiment types. LP: #1829325

 -- Dimitri John Ledkov <email address hidden> Mon, 20 May 2019 19:57:41 +0100

Changed in mdadm (Ubuntu):
status: Fix Committed → Fix Released
Dan Watkins (oddbloke) on 2019-05-21
Changed in curtin:
status: New → In Progress
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in subiquity:
status: Triaged → Fix Released
Revision history for this message
Ryan Harper (raharper) wrote : Fixed in curtin version 19.2.

This bug is believed to be fixed in curtin in version 19.2. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers