Install failed on disk previously used for ZFS

Bug #1782744 reported by Andreas Hasenack on 2018-07-20
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
subiquity
Medium
Unassigned

Bug Description

This might be a dupe of #1768384, but since that bug has no logs, I can't tell.

I tried to install on a machine with 4 disks of which two were previously part of a zpool. I used them for raid this time. The installer crashed while I was filling out my username details.

I mention ZFS because the log shows it tried to do something with zpools, even though the installer doesn't support zfs yet. Attached.

Related branches

Andreas Hasenack (ahasenack) wrote :
Andreas Hasenack (ahasenack) wrote :
Andreas Hasenack (ahasenack) wrote :
Ryan Harper (raharper) wrote :

The boot environment does not include the zfslinux-utils package.

Has that changed?

Command: ['zpool', 'list', '-H', '-o', 'name']
Reason: [Errno 2] No such file or directory: 'zpool': 'zpool'

I don't think this is a dupe of that; there was an issue with other zfs pools being activated which curtin now will remove/disable. But to do so it using zfs tools to query the system state.

Can you dpkg query system to see if any zfs packages are installed?

The live image needs to have zfslinux-utils package, or invoke curtin with --install-deps (which will check and apt install as needed).

Changed in subiquity:
status: New → Incomplete
Andreas Hasenack (ahasenack) wrote :

I switched to tty2 and checked the installed packages, there was no zfslinux-utils one installed, nor a zpool command.

OK

I'd like to see zfsutils-linux added to the image.

In the mean time, let's add a curtin task; we should handle this more
gracefully if zfsutils isn't present.
On Fri, Jul 20, 2018 at 11:50 AM Andreas Hasenack <email address hidden> wrote:
>
> I switched to tty2 and checked the installed packages, there was no
> zfslinux-utils one installed, nor a zpool command.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1782744
>
> Title:
> Install failed on disk previously used for ZFS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/subiquity/+bug/1782744/+subscriptions

Michael Hudson-Doyle (mwhudson) wrote :

When I talked to Scott about bug 1768384 he said "you shouldn't need zfsutils-linux installed to dd a few megs of zeros onto the disk" which certainly sounds plausible. I don't know why this is still an issue though, I'm pretty sure the curtin commit linked to that bug is in bionic by now.

Michael Hudson-Doyle (mwhudson) wrote :

OTOH given the release is in a few days maybe we should just add zfsutils-linux to the ISO.

Ryan Harper (raharper) wrote :

The general issue is that if a zpool is online, wiping zeros on one of the disks (which may be in a zfs raid) may not result in having a disk free for use.

That said in an environment without the zfs tools (but it does have the zfs kernel module) I don't think the pools automatically come online which means that we can zero things out.

Andreas Hasenack (ahasenack) wrote :

Switching back to "new", which I forgot to do when I added the requested information.

Changed in subiquity:
status: Incomplete → New
Scott Moser (smoser) on 2018-08-09
Changed in subiquity:
status: New → Confirmed
importance: Undecided → Medium

This bug is fixed with commit 72b02c21 to curtin on branch master.
To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=72b02c21

I'm pretty sure this is fixed now.

Changed in subiquity:
status: Confirmed → Incomplete
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers