No proxy configured post-install

Bug #1766971 reported by Andreas Hasenack on 2018-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
subiquity
Undecided
Unassigned

Bug Description

During installation, I gave the installer my local proxy address. I can't be sure at this point that it was actually used, I haven't checked the logs yet, but I'm sure it's nowhere to be seen in /etc in the installed system.

I used http://cdimage.ubuntu.com/ubuntu-server/daily-live/current/bionic-live-server-amd64.iso from Apr 25th, 2018. I'm not sure how to better identify this build, as there is no build-id in /etc/cloud.

Andreas Hasenack (ahasenack) wrote :

Grepping the installer log shows only this for my proxy input:

2018-04-25 20:18:44,505 subiquity.installpath:60 User input: {'url': 'http://ds216.lowtech:3128/'}

It's also in here:
subiquity-curtin-install.conf:proxy: {http_proxy: 'http://ds216.lowtech:3128/', https_proxy: 'http://ds216.lowtech:3128/'}

and in the installer-journal:
installer-journal.txt:Apr 25 20:18:54 ubuntu-server curtin_log.1862[2165]: merged config: {'sources': {'rofs': 'cp:///media/filesystem'}......'proxy': {'http_proxy': 'http://ds216.lowtech:3128/', 'https_proxy': 'http://ds216.lowtech:3128/'},

And in these:
curtin-install-cfg.yaml: http_proxy: http://ds216.lowtech:3128/
curtin-install-cfg.yaml: https_proxy: http://ds216.lowtech:3128/

Andreas Hasenack (ahasenack) wrote :

Just confirmed via netstat that the proxy was used during the installation.

Andreas Hasenack (ahasenack) wrote :
Andreas Hasenack (ahasenack) wrote :
Andreas Hasenack (ahasenack) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766971

tags: added: iso-testing
Michael Hudson-Doyle (mwhudson) wrote :

Well the question here is what does it mean to configure a proxy for a system? I guess we should configure apt to use the proxy at least (curtin supports this) and we could put http_proxy / https_proxy into /etc/environment but there's no guarantee that this is honoured by everything.

At least I would expect it to be in apt, and then perhaps in
/etc/environment . True that there is no guarantee every app out there
would respect /etc/environment, but it seems sensible.

On Wed, Apr 25, 2018, 19:10 Michael Hudson-Doyle <email address hidden>
wrote:

> Well the question here is what does it mean to configure a proxy for a
> system? I guess we should configure apt to use the proxy at least
> (curtin supports this) and we could put http_proxy / https_proxy into
> /etc/environment but there's no guarantee that this is honoured by
> everything.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1766971
>
> Title:
> No proxy configured post-install
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/subiquity/+bug/1766971/+subscriptions
>

Ryan Harper (raharper) wrote :

I think we need to cover exactly what's needed here:

apt proxy for installing/upgrading packages, and snap proxy for contacting the store.

I don't think a general http_proxy setting stuffed into etc/environment is going to be a good solution.

So I've just landed a change to configure a proxy for apt and for snapd in the installed system. If that's not enough, people can argue here in the bug :)

Changed in subiquity:
status: New → Fix Committed
Scott Moser (smoser) wrote :

Copied from

For more information on why "global proxy" in /etc/environment really
isn't ever sufficient, read
 https://github.com/CanonicalLtd/subiquity/pull/329#event-1633322084

Andreas Hasenack (ahasenack) wrote :

I'm fine with just apt and snap being configured for the proxy.

Changed in subiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers