Impossible to install without network

Bug #1750819 reported by Andreas Hasenack on 2018-02-21
102
This bug affects 17 people
Affects Status Importance Assigned to Milestone
subiquity
High
Unassigned

Bug Description

I'm not sure if it's expected to be able to complete an installation without networking. I was assuming I would just not get updates. But turns out the installer tries to connect to a network even if I select no not configure ipv4/ipv6 on any of my interfaces, have them disconnected (in the case of wired ones) and have not chosen any access point for the wifi ones. The installer just complains that "network configuration timed out: please verify your settings".

I noticed that the network configuration screen seems to hint that a network is needed, so feel free to mark this bug as invalid if network-less installations are not going to be supported.

Michael Hudson-Doyle (mwhudson) wrote :

I had a chat with Ryan Harper about this and we think it should be possible. We need to set kernel: {fallback_package: none} in the curtin config to avoid having curtin try to update the kernel if no network has been detected, but that /should/ be all that's required. Needs testing of course.

Changed in subiquity:
status: New → Triaged
tags: added: id-5a9fa45d495821757e1a7956
Jason Mills (virtualjmills) wrote :

The page/step header text mentioned in bug 1743623 should be updated to reflect whatever the final design/implementation settles-on.

Zhanglei Mao (zhanglei-mao) wrote :

18.04 installer would become failed in UEFI without Internet connection, but If I change UEIF to BIOS for my local VM (kvm) then it can be installed successfully after I configure an IP without actually internet access. But if I use UEFI, the install would failed and can't boot into the system. (more details can be check at duplicated LP 1770585).

Chris Carlin (crcarlin) wrote :

I also wonder what the relationship is between subiquity and Ubuntu as a whole in terms of making sure the organization and users realize its images won't be installable without networking.

If Ubuntu is putting out installation images that can't be installed without networking, that's kind of important and something they need to indicate on their download pages such as this one: http://cdimage.ubuntu.com/releases/18.04/release/

I'd suggest that someone update that download page to say networking is required, but I don't know who to suggest it to.

(but mainly I'd suggest not requiring networking in the first place)

Zhanglei Mao (zhanglei-mao) wrote :

Test with 18.04.1 iso which downloaded from http://releases.ubuntu.com/18.04.1/ubuntu-18.04.1-live-server-amd64.iso

It also can't successfully install on Huawei server without internet access to get/update packages from online repository during install. After system reboot, it shows can't find "shimx64.efi".

The install log was in attachment for reference.

Jeff Lane (bladernr) wrote :

I'm also not sure if this is related, but I noticed several Snap related issues when trying to reproduce this in a KVM.

I basically set up a KVM with a single NIC, set to private network and booted the current server Live daily ISO. In installer.log I noticed the following bits every time I tried to get passed the network setup stage (which was impossible, I kept getting dumped back to network setup even though I did not want to configure any networking).

Also, I note I may not be reproducing this exactly as Mao has, so take that into consideration. But here's the subiquity debug log from my VM with several repeated series of messages and tracebacks where I tried several times to get around the network config in subiquity.

Michael Hudson-Doyle (mwhudson) wrote :

The snap store related errors are expected if there is no network. We try to download a list of snaps to show and this obviously fails if there is no network. Subiquity should cope with this fine.

The traceback/crashes are real bugs though.

tags: added: id-5a712fd2eaad7129861532d2
Tom Reynolds (tomreyn) wrote :

Related to #1641110 (possible duplicate).

Changed in subiquity:
importance: Undecided → High
Chris Carlin (crcarlin) wrote :

Michael, but what of the original poster's comment that "the installer tries to connect to a network even if I select no not configure ipv4/ipv6 on any of my interfaces"?

I came to this bug after falling into that problem. It wasn't a crash so much as a limitation of the installer.

I know that you can't get past the network screen without entering a config, which we need to fix -- but the install does actually succeed if you provide bogus static network details you that don't work. So the remaining work is to fix the UI so you don't have to do that. This bug is not yet closed :)

Changed in subiquity:
status: Triaged → Fix Released
Pete (rosehillms) wrote :

Hi there, I have run into this problem installing onto my test server. Spec is DL580 hex core 128Gb. I am getting stuck at the network config but if I enter static or bogus ip details I get a timeout. If I select DHCP it also times out. If I select static and add a dns server location (genuine or bogus) it loops back to the start of the install at the keyboard selection options. Is there anyway around this or do I need a specific build to proceed? I can also install 16.04 without any issues. Kind regards. Pete

If you enter a static config with a gateway it should not time out. I assume you're installing bionic? The disco installer should work and I'd be interested if it does for you (although I appreciate you probably want to get an LTS installed -- 18.04.3 will have all this stuff).

Mikko Rantalainen (mira) wrote :

It turns out that the installer is dumb enough to require link up status for the ethernet port or it will not work. Connecting the server to any powered switch (link light up) will make things work and one can continue with at least "Manual" setting.

Chris Carlin (crcarlin) wrote :

So important is changed to high, but is the status still fixed released?

Sounds like people are still reporting problems.

The code change is done for the installer but we haven't released media for bionic that includes the change yet. We probably need to invent a way to make this status clear on the bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers