Directory tree doesn't auto refresh

Bug #314199 reported by afdh17 on 2009-01-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
SubDownloader
Status tracked in Trunk
Trunk
Wishlist
Alessandro Losavio

Bug Description

When you open Subdownloader, the directory tree gets loaded, however if you create a new directory this change is not reflected in the tree view. Also, if you delete a directory, you get "No video has been found" but you still get to see the directory in the tree view.
I've confirmed that with Subdownloader 2.0.9 in Debian-testing and Windows Xp

As, having to restart a program, just to get to a directory is not good, a button to refresh the tree view could be a good idea, but it would be even better if it could somehow stay actualised.

I'll take a look at the source code and see if my knowledge allows me to help

Changed in subdownloader:
importance: Undecided → Low
afdh17 (afdh17) wrote :

Hello, sorry for the delay, I've been looking around and it seems (to me) that it has nothing to do with SubDownloader but with QT itself, or the tree view widget (i.g. in k3b you have the exact same problem) I assume that there is not much the developers can do directly. And there is definitely nothing I can do to help.

Marco Rodrigues (gothicx) wrote :

Hi! Yes.. it was to do with QTreeView from QT4. We need to do something to update it. Maybe a Refresh button would be nice, but a properly fix would be better.

Changed in subdownloader:
status: New → Confirmed
Changed in subdownloader:
importance: Low → Wishlist
Changed in subdownloader:
assignee: nobody → Alessandro Losavio (alo21)
status: Confirmed → In Progress
Changed in subdownloader:
milestone: none → 2.0.16
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers