First subtitle selected in GUI

Bug #283869 reported by zagadka
4
Affects Status Importance Assigned to Milestone
SubDownloader
Confirmed
Low
Ivan Garcia

Bug Description

When using SubDownloader 2.0.7 and searching for subtitles of a specific language, or multiple languages according to your settings, the first subtitle file is always selected for download automatically upon search, even if this subtitle file is marked as having been downloaded previously. If the filter is set to "All languages" no subtitle file is automatically selected.

Revision history for this message
Ivan Garcia (capiscuas) wrote :

thks zagadka for the comment,

that's the normal behavior of the app, when somebody filter by Language we auto-select all the first subtitle of every video because in most of the cases people will like to click on the DOWNLOAD button after that and download all those subtitles without having to select 1 by 1 (in case of a series this can be a bit tedious).

What I can take from this bug is that SD should not select the subtitles that have been already downloaded.

Revision history for this message
zagadka (zagadka) wrote :

I see three things that you should consider:
1. Not selecting subtitles that has already been downloaded.
2. What to do when filtering on multiple languages which is possible because of settings. Maybe select one subtitle of each language?
3. Subtitles are allowed to be in several formats and people might have a preference for one of the formats.

This in more of a feature request than a bug report, but I can't figure out where to post feature requests.

Revision history for this message
Ivan Garcia (capiscuas) wrote :

fixed.
1. Not selecting subtitles that has already been downloaded.

Changed in subdownloader:
status: New → Fix Committed
Ivan Garcia (capiscuas)
Changed in subdownloader:
assignee: nobody → capiscuas
status: Fix Committed → Fix Released
Revision history for this message
zagadka (zagadka) wrote :

I have downloaded and installed 2.0.8, but one related thing is quite obvious. When the already downloaded subtitle is not the first on the list another subtitle file of the same language is selected. If you already have subtitles of a specific language I find it highly doubtful that you want another subtitle file of that language regardless of whether it is the first one found or not.

Revision history for this message
Ivan Garcia (capiscuas) wrote :

u are right.

Changed in subdownloader:
status: Fix Released → Confirmed
Changed in subdownloader:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers