Can't start icecast

Bug #1400018 reported by Felipe Castillo on 2014-12-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stream2ip
Medium
Takkat

Bug Description

Stream2IP is set to start and stop icecast every time it connects, but this is not possible because the default icecast2 installation and configuration (even provided in your manual) can only run with sudo.
I'm getting this error when starting stream2ip:

start-stop-daemon: unable to set gid to 128 (Operation not permitted)

I have set the last line in icecast2 to: ENABLE=true

The only way to start/stop icecast2 is with sudo. This is not such a big problem when icecast2 is set to start everytime when the system is booted. Nonetheless the error message appears and should be looked into. Maybe just check that icecast2 is running already and if so, don't try to start/stop it. In the case it's not running, then that would be a bigger problem given that we need sudo to start it.

Takkat (takkat-nebuk) wrote :

Thank you for reporting this.

We confirm that Icecast2 can't set the GID if not run as root, and we do have the error message.

All systems here are still able to start the Icecast server without issues. Therefore asking for root priviledges was not an option.

Can you confirm that the Icecast2 server is running after starting it from stream2ip (`pidof icecast2') ?

Changed in stream2ip:
status: New → Incomplete
assignee: nobody → Takkat (takkat-nebuk)
Felipe Castillo (fcastillo.ec) wrote :

I'm attaching the terminal output when I run stream2ip from the terminal in verbose mode.
Before running this I made sure that Icast2 was not running at all and if it was running I stopped it. This way I could see if stream2ip is able to start icecast2 or not.
As you can see in the output, stream2ip can't start icecast (i checked using 'pidof' and no process was found), I still get the error that the operation is not permited. This also makes darkice not to be able to work.
Before I posted this bug, i made sure to google icecast2 behaivor and it appears that all the blogs I've found say that you can only start/stop icecast2 with sudo, otherwise it won't work.

Takkat (takkat-nebuk) wrote :

As a workaround we have to start Icecast at system start.

For the upcoming version 1.0.6 we will add a routine to check for a running Icecast server to then start it on demand.

Thank you for your help on this.

Changed in stream2ip:
status: Incomplete → Confirmed
importance: Undecided → Medium
Felipe Castillo (fcastillo.ec) wrote :

Thanks for looking into the issue, I'll be looking forward for the update.

Let me see if I understand what you mean by "we will add a routine to check for a running Icecast server to then start it on demand."
Starting icecast at system start is the only way I can see this working, and checking if it's running already is excellent. How are you going to start icecast on demand (assuming it didn't start at system start)? Are you going to require sudo or is there another way to do this?
I'm just wondering for my own learning, thanks!

Takkat (takkat-nebuk) wrote :

We will be running Icecast in userspace in case it was not started as a service on boot. Coding and testing will take some time so be patient.

Changed in stream2ip:
status: Confirmed → In Progress
Takkat (takkat-nebuk) wrote :

Please find the issue fixed in release 1.0.6 ready for download as source or DEB.

In case there are any further issues don't hesitate to report them. Thank you.

Changed in stream2ip:
status: In Progress → Fix Released
Takkat (takkat-nebuk) on 2014-12-20
Changed in stream2ip:
milestone: none → 1.0.
Takkat (takkat-nebuk) on 2015-04-04
Changed in stream2ip:
milestone: 1.0. → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments