Problems to load Graphics

Bug #1193914 reported by Waldi on 2013-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stream2ip
Medium
Takkat

Bug Description

if I start start2ip the following error occour:

Traceback (most recent call last):
  File "s2ip_setup.py", line 321, in <module>
    SetupIcn = GdkPixbuf.Pixbuf.new_from_file(setupIcon)
  File "/usr/lib/python3/dist-packages/gi/types.py", line 72, in constructor
    return info.invoke(cls, *args, **kwargs)
gi._glib.GError: Couldn't recognize the image file format for file '/usr/share/stream2ip-gtk3/icons/S2-setup.svg'

Python 3.2.3
stream2ip 1.0.5

Whats wrong?

Waldi

Takkat (takkat-nebuk) on 2013-06-24
Changed in stream2ip:
assignee: nobody → Takkat (takkat-nebuk)
importance: Undecided → Medium
Takkat (takkat-nebuk) wrote :

Thank you for reporting this.

Can you please add your distribution and release version?

Waldi (waldi1985) wrote :

With Ubuntu 12.10 (Quantal Quetzal) the error occour, on 12.04 LTS (Precise Pangolin) it runs fine.

Waldi

Takkat (takkat-nebuk) wrote :

Tests here on a vanilla 12.10 installation can not reproduce the issue you reported.

I believe that your installation got corrupted somehow. Try to purge stream2ip-gtk3 and reinstall. In case you downloaded the .DEB package please also download the package again.

Don't hesitate to report if the issue still exists. You then may also run stream2ip with option -v in a terminal to give us more details on possible errors.

Thank you again for reporting the issue.

Waldi (waldi1985) wrote :

It isn't a problem for me if stream2ip doesn't run, but I think it can help you if I report the error.

I've try to reinstall the stream2ip but no success.... Sorry

stream2ip -v give the same output:

Traceback (most recent call last):
  File "/usr/share/stream2ip-gtk3/stream2ip.py", line 35, in <module>
    import s2ip_setup
  File "/usr/share/stream2ip-gtk3/s2ip_setup.py", line 321, in <module>
    SetupIcn = GdkPixbuf.Pixbuf.new_from_file(setupIcon)
  File "/usr/lib/python3/dist-packages/gi/types.py", line 72, in constructor
    return info.invoke(cls, *args, **kwargs)
gi._glib.GError: Couldn't recognize the image file format for file '/usr/share/stream2ip-gtk3/icons/S2-setup.svg'

If I can do anything for you, let me know I can try it and give you the information.

Waldi

Takkat (takkat-nebuk) wrote :

I do appreciate your help very much!

Can you please try if the error goes away by copying another icon over the presumably corrupted `/usr/share/stream2ip-gtk3/icons/S2-setup.svg' (rename the S2-setup.svg first to be able to restore it) - this would then tell us that it is the .svg file which is corrupted.

Takkat (takkat-nebuk) wrote :

Actually, it may already reveal a broken SVG if you tried to view it with an image viewer. Do you get any errors then?

Waldi (waldi1985) wrote :

The svg Images are displayed correctly in chrome and firefox.

Yesterday, I've installed another software which has the librsvg2-common as dependency. Since there stream2ip works well. I think you must have installed this lib.

Waldi

Takkat (takkat-nebuk) on 2013-06-26
Changed in stream2ip:
status: New → Fix Committed
Takkat (takkat-nebuk) wrote :

Oh I see - this makes sense.

We removed the rsvp dependency on switching to Python3 and GTK3 because all desktop variants now have librsvg2 installed per default. This may not be the case when installing another desktop, running the server edition, or on a customized desktop.

We then need to install `librsvg2-common' to be able to render SVG icons. I will include this as a dependency in the next release to address this.

Thank you for pointing out!

Takkat (takkat-nebuk) on 2015-05-26
Changed in stream2ip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers