Stratagus doesn't build for lua 5.2. I have created a patch.

Bug #993364 reported by worldcitizen on 2012-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Joris Dauphin

Bug Description

Stratagus doesn't build for lua 5.2. I have created a patch.

Related branches

Changed in stratagus:
assignee: nobody → Joris Dauphin (joris-dauphin)
Joris Dauphin (joris-dauphin) wrote :

Patch not applied (too many #ifdef)

Since getglobal is supported with previous version, I use it instead of "gettable(GLOBAL_INDEX)"
Add an inline function for the renaming of objlen/rawlen (I use the 5.2 syntax in the code).

The code is shorter with the new syntax :-)

Changed in stratagus:
status: New → Fix Committed
milestone: none → 2.2.7
Joris Dauphin (joris-dauphin) wrote :

Note that I didn't see any version of ToLua++ that is compatible with Lua 5.2

Pali (pali) on 2012-08-20
Changed in stratagus:
status: Fix Committed → Fix Released
Thaodan (theodorstormgrade) wrote :

The patch don't fixes anything still getting:
/usr/bin/tolua++: symbol lookup error: /usr/bin/tolua++: undefined symbol: luaL_newstate
make[2]: *** [tolua.cpp] Fehler 127

worldcitizen (joop-boonen) wrote :

This patch was to fix the stratagus part.
The problem is as mentioned above that tolua++ doesn't support lua5.2 .
I've Partly fixed tolua++ (except the script part ). I've contacted the developer for help, but I didn't get a reply, i think from the current developers side i have the feeling the project is dead.

I think if it's possible it would be better to use tolua in stead of tolua++.
As tolua supports lua 5.2.
http://www.tecgraf.puc-rio.br/~celes/tolua/

worldcitizen (joop-boonen) wrote :

As an addition to the latest post. If someone wants to help we can also port tolua++ to lua 5.2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers