Units don't repair buildings

Bug #982532 reported by Travis on 2012-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Unassigned

Bug Description

Was playing a skirmish map this morning to test the game out, and some dragons came up and started hurling flame on my gaurd towers. I went to repair them and the peasents did one stroke of repair work before complaining I had no gold or lumber to repair them with...I had 2,600 gold and 1800 lumber, so there's a bug there somewhere.

- By the way that include/vector (line 932) - https://bugs.launchpad.net/bugs/976937 error is still happening when I try and load a game - I've got revision 8210 running - about to get revision 8211.

cybermind (iddqd-mail) wrote :

Just wait, i've fixed it, but haven't uploaded the fix yet

Changed in stratagus:
status: New → In Progress
Travis (dinky-dye-aussie) wrote :

The "loading a game then crashing bug?" or the "not being able to repair bug?"

Either one is a step in a positive direction, just anxious to get this loadgame bug out of the way, then (I think) it should be pretty close to A+ runtime status.

Travis (dinky-dye-aussie) wrote :

Thanks for fixing the repair bug man. I am still having problems with the save games not loading and causing that vector crash still...I'm not sure what is causing it, but if I run it in debug mode all I get before it crashes is information that it starts loading the tileset and then it crashes out to the desktop.

It might be a script problem, but I'm sure it's engine code to be honest.

Joris Dauphin (joris-dauphin) wrote :

Can you provide the savegame ?

Travis (dinky-dye-aussie) wrote :

yeah I can do that.

It's the only savegame I got at the moment that I saved with build 8212. I hope it helps somehow.

Joris Dauphin (joris-dauphin) wrote :

I was able to reproduce the crash :-)

As you can see in the call stack,
it was due to indexing a ai-force vector (of size 3) out of bound.

Fixed in trunk rev.8218

Changed in stratagus:
status: In Progress → Fix Committed
milestone: none → 2.2.7
Pali (pali) on 2012-08-20
Changed in stratagus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments