Build 8152 not loading games from savegame files

Bug #960299 reported by Travis on 2012-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Joris Dauphin

Bug Description

It just won't load any game from a save, at all. I am convinced it is to do with the changes made to build 8150. This load error needs to be fixed asap. build 8148 never did this.

Related branches

Travis (dinky-dye-aussie) wrote :

It starts loading the tileset (in this case summer) then just quits. I ran it in debug mode and it said there was a problem in unit.cpp - the first problem anyway.

Anyway I think it has something to do with loading saves from a previous version of the game. I just tried saving a campaign level and exiting, restarting and loading the freshly saved game, and it worked. I'll keep testing though to see how that goes once I progress through the level a bit more and see if when I save it again once progress is made, it crashes. I will keep reporting my findings.

Joris Dauphin (joris-dauphin) wrote :

bug has been introduced in 8149. bug appeared when loading a dying unit.
Fixed in 8154.

Changed in stratagus:
assignee: nobody → Joris Dauphin (joris-dauphin)
status: New → Fix Committed
Travis (dinky-dye-aussie) wrote :

That worked Joris, but it's back in 8157! I dont know what Cybermind has done to build 8157 to make it not work, but the fix you put in to make it work isn't working now...I've tried every savegame and none of them load - it's back t crashing when loading the tileset...

Travis (dinky-dye-aussie) wrote :

I just compiled revision 8156 and it loaded the game save files perfectly, so there's a bug somewhere in 8157.

cybermind (iddqd-mail) wrote :

Sorry, i forgot to comment that i'm made some changes in savegame format that it will support a lot of user defined variables, so old saves won't work anymore, just make a new save in 8157 and try to load it

Pali (pali) on 2012-04-19
Changed in stratagus:
milestone: none → 2.2.7
Pali (pali) on 2012-08-20
Changed in stratagus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers