unit unable to find path to goal if unit is next to goal

Bug #912904 reported by Neil Tan on 2012-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Pali

Bug Description

In stargus map (3)Holy Ground, grass land is mistakenly converted into an unpassable tile. This blocks in a particular SCV unit on this map. The unit is also surrounded by minerals and the command center. It is completely surrounded by things it can't pass. The only thing it can do is harvest the minerals surrounding part of it. When it finishes harvesting, it doesn't unload the minerals to the command center which is right beside it. It does nothing. You have to give it a command to return to the command center for it to unload the minerals. The problem is that the path finding routine sees the unit as a non moving unit blocking itself from the command center. The attached patch against stratagus-2.2.6 fixes this.

Related branches

Neil Tan (emtneutrino) wrote :
Neil Tan (emtneutrino) on 2012-01-06
description: updated
Pali (pali) on 2012-01-07
Changed in stratagus:
status: New → Fix Committed
assignee: nobody → Pali (pali)
Pali (pali) on 2012-04-19
Changed in stratagus:
milestone: none → 2.2.7
Pali (pali) on 2012-08-20
Changed in stratagus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers