Assertion failed at unit/unit.cpp:340: RestoreOrder: !this->CurrentOrder()->HasGoal()

Bug #871354 reported by Avg on 2011-10-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Unassigned

Bug Description

stratagus at revision 8000.
wargus is at 1598.

Avg (avg) wrote :
Pali (pali) wrote :

Can you reproduce this crash? Or it is crashing randomly? Check this problem is still in version 2.2.6. Also please specify your OS.

cybermind (iddqd-mail) wrote :

This bug still happens in 2.2.6. I checked the reason and it was that in some occurrences pathfinder returns PF_REACHED if unit tries to attack other unit, but map distance to target is bigger to 1 than the unit's attack range. So unit can't attack and when tries to restore action, this assertion fails.

Joris Dauphin (joris-dauphin) wrote :

My fault, it should be fixed in trunk now.

cybermind (iddqd-mail) wrote :

No, it still happens with 8039 revision

Joris Dauphin (joris-dauphin) wrote :

Stuff has been rewrote. this Assert is no more present.

Changed in stratagus:
status: New → Fix Released
Changed in stratagus:
milestone: none → 2.2.7
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers