OpenGL is slower than without OpenGL

Bug #710187 reported by belgther on 2011-01-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
High
cybermind

Bug Description

OS: Windows XP SP3
Graphics Card: NVidia 8600M GS
Driver Version 258.96

When I turn OpenGL on, the game becomes much slower and I get 5-6 FPS.

Related branches

Pali (pali) wrote :

This is know problem in Stratagus engine.

affects: wargus → stratagus
Changed in stratagus:
importance: Undecided → High
status: New → Confirmed
summary: - OpenGL in Wargus is slower than without OpenGL
+ OpenGL is slower than without OpenGL
Pali (pali) wrote :

Can you check if this problem is in game BosWars too?
URL: http://www.boswars.org

cybermind (iddqd-mail) wrote :

Reason of this bug:
it's because of SDL 1.2.1.4
just need to install SDL 1.2.1.3

Pali (pali) wrote :

I have SDL version 1.2.13 and I have problem with OpenGL too.

cybermind (iddqd-mail) wrote :

I don't have this bug anymore, check if it still happens

Changed in stratagus:
status: Confirmed → Fix Committed
Travis (dinky-dye-aussie) wrote :

OpenGL runs smooth, except the water and water lapping at ships hulls etc doesn't animate when OpenGL is turned on.

Pali (pali) on 2012-04-19
Changed in stratagus:
milestone: none → 2.2.7
assignee: nobody → cybermind (iddqd-mail)
Pali (pali) on 2012-08-20
Changed in stratagus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers