[Maemo] Problem with cursor

Bug #621815 reported by torpedo48 on 2010-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Critical
Pali

Bug Description

- Open Wargus and start a game (I've tried only the orc campaign

- Leave Wargus on the background for a while using Ctrl+Backspace on your N900

- Resume Wargus and try to use the cursor: it has become messed up. You will not be able to select just one unit (it will select all the units of the clicked type visible on the screen) and strange behaviour will happen.

Related branches

Pali (pali) wrote :

The problem is in handling left and right mouse buttons in stratagus. On Maemo is only "left" button and "right" is simulated by "left double click".

I see some other problem with problems with "double click". I try fix this.

affects: wargus → stratagus
Changed in stratagus:
assignee: nobody → Pali (pali)
importance: Undecided → Critical
status: New → Confirmed
summary: - When left on background and resumed, Wargus messes up the cursor
+ [Maemo] Problem with cursor
Pali (pali) on 2010-08-22
tags: added: maemo
Pali (pali) on 2010-11-02
Changed in stratagus:
status: Confirmed → In Progress
status: In Progress → Fix Committed
Pali (pali) on 2010-11-23
Changed in stratagus:
milestone: none → 2.2.5.5
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers