issues in rev 8836: stratagus/iolib.cpp:543:62: error: ‘MAX_PATH’ was not declared in this scope and others

Bug #1245643 reported by Václav Šmilauer on 2013-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stratagus
Fix Released
Undecided
Joris Dauphin

Bug Description

There is a number of issues with rev 8836 (I am compiling under Ubuntu 13.04 with gcc 4.7):

MAX_PATH is used in the code, which is not defined under Linux. Adding

  #define MAX_PATH PATH_MAX

at the beginning of stratagus/iolib.cpp solved the issue for me. Perhaps the places where MAX_PATH is used should be replaced by PATH_MAX.

Additional related errors:

src/video/mng.cpp:324

 LibraryFileName(name.c_str(), buf, sizeof(buf));

does not match the function declaration (it has only one parameter and returns a value).

Perhaps there is more issues, I reverted to rev 8826 to make stratagus compile under Linux.

Related branches

Changed in stratagus:
assignee: nobody → Joris Dauphin (joris-dauphin)
Joris Dauphin (joris-dauphin) wrote :

Should be fixed in rev.8838 (untested).
Thanks to report new status.

Changed in stratagus:
status: New → Fix Committed
Tilpa (fabio-pasini) wrote :

It was broken here last week, now it compiles ok

Tested revision 8838 on a Ubuntu 10.04.4 LTS box.

Václav Šmilauer (eudoxos) wrote :

Confirming the issue is solved for me as well with 8838.

cybermind (iddqd-mail) on 2015-03-19
Changed in stratagus:
status: Fix Committed → Fix Released
milestone: none → 2.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers