timeouterror could be more clear about the implications

Bug #617973 reported by Robert Collins on 2010-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Storm
Low
Jamu Kakar

Bug Description

When TimeoutError is raised the exception looks like the query was run-and-timed-out, but actually it isn't run.

So perhaps if the exception had two parts - a reason, and the query (or perhaps a new class name?).

I'd like a reason myself:
TimeoutError('-4 seconds remaining in time budget', 'SELECT....')
TimeoutError('SQL server cancelled transaction', 'SELECT....')

The lack of clarity here means that new developers reading OOPS reports in launchpad for the first time have to go read the storm source to see what is actually meant by a TimeoutError - and they don't, because they *think* they know what TimeoutError means when they first see it.

Related branches

Jamu Kakar (jkakar) on 2010-08-14
Changed in storm:
milestone: none → 0.18
importance: Undecided → Low
status: New → Confirmed
Jamu Kakar (jkakar) on 2010-08-14
Changed in storm:
status: Confirmed → In Progress
assignee: nobody → Jamu Kakar (jkakar)
Jamu Kakar (jkakar) on 2010-08-16
Changed in storm:
status: In Progress → Fix Committed
Gary Poster (gary) on 2010-10-26
Changed in storm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers