Error during stk installation

Bug #1171862 reported by Giacomo Picchiarelli on 2013-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stk-c
Critical
Federico Razzoli

Bug Description

returns

[dbconManager] Unexpected error: <class '_mysql_exceptions.ProgrammingError'>
(1064, "You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'DELIMITER ||\r\n\r\n##begin\r\n\r\n\r\n-- make the server as strict as possible\r\n-- TO-DO:' at line 21")

I'm using 10.0.1-MariaDB-mariadb1~precise-log mariadb.org binary distribution

Perhaps I'm wrong using the executeStatement function could you please check it out?

Changed in stk-c:
importance: Undecided → Critical
assignee: nobody → Federico Razzoli (santec)
description: updated
Federico Razzoli (santec) wrote :

This is not a bug: DELIMITER is a client command and is there in case you install from the command line:
mysql < stk_unit.sql
, but the C api (used by all languages) can't handle that command.

This problem will be solved when stk/c is able to exclude all lines before "##begin" and after "##end".
DELIMITER commands will be exluded.

Changed in stk-c:
status: New → Invalid
Changed in stk-c:
status: Invalid → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers