Satellites plugin cause crash when enabled in distant past

Bug #955780 reported by Matthew Gates on 2012-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Bogdan Marinov

Bug Description

If the Satellites plugin is enabled when the simulation time is in the distant past (e.g. 1000 CE), Stellarium crashes.

Fixing the immediate cause of the crash as described is only a band aid, and is actually indicative of a wider issue with the Satellites plugin. TLE data is only really valid for a fairly short period of time (weeks to months). After a few years, TLE derived orbits start to look pretty weird (for example, at +1 year, meteor 1-1 zooms around at impossible speeds), and after longer periods it gets truly absurd.

This isn't something specific to Stellarium's implementation, it's just that the orbital calculation method is not designed or capable to handling long time-frames. Such is the nature of the beast.

In my view, there should be some sort of cut-off point after which the Satellites plugin does not try to render a Satellite. I would like to do it like this:

1. Find out if there is a good method for determining the validity period for the Satellites position
2. In the Satellite object, store this validity period, as calculated from the last TLE update date
3. Only calculate position & render the Satellite if the simulation time is within this validity range.

I have previously thought about this issue a few times, and there is a design problem... Satellites will simply vanish from the sky when the simulation date exceeds the bounds of this range of valid dates. I don't really know how to address this in a manner which won't cause a flurry of bug reports. Certainly documentation can help somewhat. I also think a message should be displayed if there are no Satellites available because the sim date is outside the valid range for all enabled satellites. That message can be displayed in the same manner as the oculars "please select an object before switching to oculars view" message.

Sergey (sergeyvist) on 2012-04-17
Changed in stellarium:
assignee: Matthew Gates (matthew-porpoisehead) → Sergey (sergeyvist)
Changed in stellarium:
milestone: 0.11.3 → none
Changed in stellarium:
assignee: Sergey (sergeyvist) → nobody
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 6082 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/6082

Changed in stellarium:
milestone: none → 0.12.2
assignee: nobody → Bogdan Marinov (daggerstab)
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers