solar system observer planets and distance

Reported by Ryan Mo on 2011-07-09
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Unassigned

Bug Description

In the location 'planet' "Solar System Observer", the solar system is too far in distance to observe, and when you zoom in on the planets they disappear and leave their glow or disappear entirely. I have tried turning the "Dynamic Eye Adaption" setting off, and this only allows some of the outer satellites (i.e. Pluto) to actually appear when the whole system is in view. Also, I have tried setting the orbit_SemiMajorAxis and even the orbit_Period (both of the [solar_system_observer] setting within ssystem.ini) to a much lower number than it previously had been. I need this outside perspective for specific calculations.

2011-07-08T22:58:11
Unsupported Windows version
Compiled with GCC 4.4.0
Qt runtime version: 4.7.1
Qt compilation version: 4.7.1
Addressing mode: 32-bit
Total memory: 4095 MB (unreliable)
Total virtual memory: 2047 MB (unreliable)
Physical memory in use: 29%
Processor speed: 3009 MHz
Processor name: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
Processor speed: 3009 MHz
Processor name: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
C:\Program Files (x86)\Stellarium\stellarium.exe
 ---------------------------------------------------------
[ This is Stellarium 0.10.6.1 - http://www.stellarium.org ]
[ Copyright (C) 2000-2010 Fabien Chereau et al ]
 ---------------------------------------------------------
Writing log file to: "C:/Users/Ryan/AppData/Roaming/Stellarium/log.txt"
File search paths:
  0 . "C:\Users\Ryan\AppData\Roaming\Stellarium"
  1 . "."
Config file is: "C:\Users\Ryan\AppData\Roaming\Stellarium/config.ini"
OpenGL supported version: "2.1.2"
Qt GL paint engine is: "OpenGL2"
Cache directory is: "C:\Users\Ryan\AppData\Local\stellarium\stellarium\cache"
Sky language is "en"
Application language is "en"
Loading Solar System data ...
Loaded 38 / 38 planet orbits from "C:\Users\Ryan\AppData\Roaming\Stellarium/data/ssystem.ini"
Loading star data ...
"Loading "./stars/default/stars_0_0v0_1.cat": 0_0v0_1; 5013"
"Loading "./stars/default/stars_1_0v0_1.cat": 1_0v0_1; 21999"
"Loading "./stars/default/stars_2_0v0_1.cat": 2_0v0_1; 151416"
"Loading "./stars/default/stars_3_1v0_0.cat": 3_1v0_0; 434064"
"Loading "C:\Users\Ryan\AppData\Roaming\Stellarium/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
"Loading "C:\Users\Ryan\AppData\Roaming\Stellarium/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
"Loading "C:\Users\Ryan\AppData\Roaming\Stellarium/stars/default/stars_6_2v0_0.cat": 6_2v0_0; 26615233"
Finished loading star catalogue data, max_geodesic_level: 6
Warning: location "Solar System Observation," is unknown.
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 222 / 222 NGC name records successfully
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Creating GUI ...
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "C:\Users\Ryan\AppData\Roaming\Stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2
Loaded plugin "Satellites" .
Satellites::getJsonFileVersion() version from file: "0.6.4"
Satellites::init using satellite.json file: "C:\Users\Ryan\AppData\Roaming\Stellarium/modules/Satellites/satellites.json"
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .

Related branches

Changed in stellarium:
status: New → Confirmed
milestone: none → 1.0.0
Bogdan Marinov (daggerstab) wrote :

It is very hard to make at the same time "nice" and accurate "top-down view" of the Solar System, simply because of the sheer scale of the sizes and distances involved. The Solar System is *huge*:
http://www.phrenopolis.com/perspective/solarsystem/

Ryan Mo (rymo4u) wrote :

Yeah, but the current Solar System Observer perspective is completely out of range. It's already a "nice" and "top-down" view, but it's zoomed out until at the standard zoom scale it's only a few pixels across. So I don't think the solar system being too "huge" has anything to do with it. It needs to be blown up. Like I said, I decreased the amount of miles under the SemiMajorAxis setting, where others have had better results, mine didn't change at all.

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
milestone: 1.0.0 → 0.11.2
importance: Undecided → Low
status: Confirmed → In Progress
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 5129 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/5129

Distance between solar system observer and Sun now 230 A.U. instead over 6000 A.U.

Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
Alexander Wolf (alexwolf) wrote :

I'm reopen this bug because we having it again.

Changed in stellarium:
importance: Low → Medium
milestone: 0.11.2 → 0.12.0
status: Fix Released → Triaged
Argafål (argafal) wrote :

Hi, I'm wondering whether there's been any news regarding the disappearing planets? It is affecting me and about 15 other people of a course where one of the tasks is to observe the lunar phases from "above" the earth-moon plane.

Alexander Wolf (alexwolf) wrote :

Well, Sun and planets not have textures for views from many TNO objects. :(

Changed in stellarium:
importance: Medium → High
Alexander Wolf (alexwolf) wrote :

Planet have troubles with textures for distance since 50 A.U.

Ryan Mo (rymo4u) wrote :

The Solar System Observer distance is much better/closer in 0.11.4. Although there are still disappearing textures.

Weisson Ang (weisson123) on 2013-01-18
Changed in stellarium:
status: Triaged → Incomplete
assignee: Alexander Wolf (alexwolf) → nobody
Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: Incomplete → Triaged
Changed in stellarium:
milestone: 0.12.0 → 0.12.1
assignee: Alexander Wolf (alexwolf) → nobody
Alexander Wolf (alexwolf) wrote :

I'm apply workaround for this issue for 0.12.0 but it not solve problem, just mask it.

Diff: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/5767

Alexander Wolf (alexwolf) wrote :

Well, I can reproduce this bug on 0.10.6 too. I think this bug was introduced very long time ago. :(

Changed in stellarium:
importance: High → Critical
Bogdan Marinov (daggerstab) wrote :

"Critical" is for bugs that affect the software in a major way. Read: crashes and major interface failures.

Changed in stellarium:
importance: Critical → Medium
Alexander Wolf (alexwolf) wrote :

I can reproduce this bug on 0.10.3 too :(

Changed in stellarium:
milestone: 0.12.1 → none
tags: added: solar-system
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers