Altazimutal grid not overlapping equatorial grid when located on poles

Reported by Fabien Chéreau on 2011-05-02
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Shantanu Agarwal

Bug Description

Hi.

Here is another question for you:

I have heard that at the onset of Spring Equinox, somewhere along the Equator, the Sun will be directly overhead of an observer.

Directly overhead implies the object is at 90 degree elevation or zero degrees zenith.

Stellarium interface provides an option to view Azimuthal Grids which meet at a point in the sky which looks like it could be the Zenith. However, the Ecliptic doesn't look like it ever crosses that point. If it is true the at the moment of Equinox the Sun will be directly overhead shouldn't the Ecliptic cross the zenith at the same moment in time on both the Equinoxes, Spring and Automnal?

To test this I created a North Pole location, N 90 degrees and E 0 degrees. Looking directly overhead it looks like Azimuthal Grid and Equilateral grids are not co-centric as I thought they should be. They are slightly off. I am sure there is a good reason for it.

Thanks for your help and input.

Farzad

Related branches

Changed in stellarium:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 1.0.0
Massimo Ramella (ramella) wrote :

Hi

The difference between the directions of the poles of the Alt-Az and Equatorial system is about half a degree. This is really quite a difference! There is no difference between the two systems at the equator.

For me, teaching childern about coordinate systems, this is a problem....

Cheers
Massimo

Shantanu Agarwal (shantanuag) wrote :

Hi

I've tried to correct the problem (a very minor change). Initially, any position above 89.5°N (or for anything below 89.5°S) was treated as having latitude 89.5° for the purpose of drawing the equatorial grid. This may be because the equatorial grid was obtained by transforming the altaz grid, and altaz coordinates are not defined on poles. But interestingly, stellarium makes an altaz grid for poles as well, and they can be thought of as a limit of latitude going to 90.0° along the specified longitude. So, the poles need not be treated as special and the same transformation matrix may be used on them as well. I hope I am correct. Please comment.

I have attached the patch file.

Alexander Wolf (alexwolf) wrote :

I'll look your patch tonight

Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 5270 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/5270

Changed in stellarium:
milestone: 1.0.0 → 0.11.3
status: Confirmed → Fix Committed
assignee: nobody → Shantanu Agarwal (shantanuag)
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions