flag_show_fps = false & flag_show_fov = flase (not working)

Reported by Keatah on 2011-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Wishlist
Alexander Wolf

Bug Description

When editing the config.ini file, the option of displaying (or not) the FPS counter does not respond.
The FPS is constantly showing and will not go away when adding "flag_show_fps = false" to the file.
Same thing happens the "flag_show_fov = false" option..

This is in version 0.10.6.1
2011-03-03T02:43:21
Windows XP
Compiled with GCC 4.4.0
Qt runtime version: 4.7.1
Qt compilation version: 4.7.1
Addressing mode: 32-bit
Total memory: 2014 MB (unreliable)
Total virtual memory: 2047 MB (unreliable)
Physical memory in use: 49%
Processor speed: 1694 MHz
Processor name: Intel(R) Pentium(R) M processor 1.70GHz
C:\Program Files\Stellarium\stellarium.exe --safe-mode
 ---------------------------------------------------------
[ This is Stellarium 0.10.6.1 - http://www.stellarium.org ]
[ Copyright (C) 2000-2010 Fabien Chereau et al ]
 ---------------------------------------------------------
Writing log file to: "C:/Documents and Settings/Owner/Application Data/Stellarium/log.txt"
File search paths:
  0 . "C:\Documents and Settings\Owner\Application Data\Stellarium"
  1 . "."
Config file is: "C:\Documents and Settings\Owner\Application Data\Stellarium/config.ini"
OpenGL supported version: "1.3.0 - Build 4.14.10.4497"
Qt GL paint engine is: "OpenGL"
Cache directory is: "C:\Documents and Settings\Owner\Local Settings\Application Data\stellarium\stellarium\cache"
Sky language is "en"
Application language is "en"
Loading Solar System data ...
Loaded 38 / 38 planet orbits from "C:\Documents and Settings\Owner\Application Data\Stellarium/data/ssystem.ini"
Loading star data ...
"Loading "./stars/default/stars_0_0v0_1.cat": 0_0v0_1; 5013"
"Loading "./stars/default/stars_1_0v0_1.cat": 1_0v0_1; 21999"
"Loading "./stars/default/stars_2_0v0_1.cat": 2_0v0_1; 151416"
"Loading "./stars/default/stars_3_1v0_0.cat": 3_1v0_0; 434064"
"Loading "C:\Documents and Settings\Owner\Application Data\Stellarium/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
"Loading "C:\Documents and Settings\Owner\Application Data\Stellarium/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
"Loading "C:\Documents and Settings\Owner\Application Data\Stellarium/stars/default/stars_6_2v0_0.cat": 6_2v0_0; 26615233"
"Loading "C:\Documents and Settings\Owner\Application Data\Stellarium/stars/default/stars_7_2v0_0.cat": 7_2v0_0; 57826266"
ERROR: SpecialZoneArray( 8 )::SpecialZoneArray: QFile( "C:/Documents and Settings/Owner/Application Data/Stellarium/stars/default/stars_8_2v0_0.cat" .map( 5242912 , 701538504 ) failed: "Not enough storage is available to process this command."
"Loading "C:\Documents and Settings\Owner\Application Data\Stellarium/stars/default/stars_8_2v0_0.cat": 8_2v0_0; - initialization failed"
Finished loading star catalogue data, max_geodesic_level: 7
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 222 / 222 NGC name records successfully
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Creating GUI ...
Loaded plugin "AngleMeasure" .
AngleMeasure plugin - press control-A to toggle angle measure mode
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "C:\Documents and Settings\Owner\Application Data\Stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2
Loaded plugin "Satellites" .
Satellites::getJsonFileVersion() version from file: "0.6.4"
Satellites::init using satellite.json file: "C:\Documents and Settings\Owner\Application Data\Stellarium/modules/Satellites/satellites.json"
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TextUserInterface" .
init called for TextUserInterface
Loaded plugin "TimeZoneConfiguration" .

Related branches

Bogdan Marinov (daggerstab) wrote :

Where did you get these, the user manual? It's out of date and poorly maintained. I think that these two flags haven't been in use since the beginning of the 0.10.* series. The code that handles them no longer exists.

If you want to hide the toolbars, including the small info strip in the bottom, you can use Ctrl+T. Pressing it again switches them on again. Unfortunately, it's not persistent, i.e. there's no option in the configuration file for that.

I'll leave this bug report open in case someone want to re-implement this feature or something similar (persistence of the Ctrl+T thing).

Changed in stellarium:
importance: Undecided → Wishlist
status: New → Confirmed
Keatah (keatah) wrote :

Those are listed in Appendix A of the manual, yes.
I would just prefer to to hide the FPS indicator, and be able to hide/show it independently of the menu/Ctrl-T thing.

Changed in stellarium:
milestone: none → 0.11.1
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → In Progress
Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers