Planet trails are buggy in some projection modes

Bug #724868 reported by Bogdan Marinov on 2011-02-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Guillaume Chereau

Bug Description

Planet trails are buggy in some projection modes.

Affected projection modes:
- perspective (phantom fragments of the trails are projected in the wrong places and move independently from the star field)
- Hammer-Aitoff (probably a separate problem - trails are not rendered correctly when their ends are on opposite sides of the projected star field)
- cylinder (same problem as with Hammer-Aitoff)
- Mercator (same problem as with Hammer-Aitoff)
- orthographic (same problem as with perspective projection)

See this thread in the Feedback forum for the user report that prompted this bug report:

tags: added: solar-system
Changed in stellarium:
milestone: 1.0.0 → none
Changed in stellarium:
assignee: nobody → Guillaume Chereau (guillaume-chereau)
tags: added: projection

I notice that the meteors also have strange trajectories with some projection modes (at least in perspective projection). I haven't checked much into it, but it might be related.

Alexander Wolf (alexwolf) wrote :

Seems we have errors in clipping part of projections. I think this issue - - related too.

The bug of the perspective projection is due to a clipping problem. I can fix it with this small patch, but I am not sure this won't introduce some other bugs, so I haven't committed yet.

Alexander Wolf (alexwolf) wrote :

Apparently this patch fixes bug #1450211 also. Plus I can't see problems with planet trails and meteors with him. And I don't see visible problem with projection.

Changed in stellarium:
milestone: none → 0.14.0
status: Confirmed → In Progress

OK, if you think that is acceptable, then I can commit it, and we can still revert if we find some bugs later.

Alexander Wolf (alexwolf) wrote :

Yes, it's OK for me.

Alexander Wolf (alexwolf) wrote :

Guillaume, what about other projections?

I am not really sure about the other projections. The planet trails rendering is a bit strange on my machine: if I select a planet the trail disappears, and I cannot bring it back, even with shift-T. Do we have some screenshots that show the problem?

Alexander Wolf (alexwolf) wrote :

Please try set viewing/flag_isolated_trails = false to get old behaviour for trails

OK I can see it now. We need to check for segments intersecting the viewport discontinuity like StelPainter::drawSmallCircleArc does. I think we should add a more generic method of StelPainter to draw a line from a list of points. I am going to have a look at it.

I just pushed a change that should fix the problem: r7647.

Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers