(Not so) Random crash on exit

Bug #600444 reported by Peter Mousley on 2010-07-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Low
Unassigned

Bug Description

I was getting seemingly random crashes when exiting, but have tracked down the problem...

The crash occurs if you quit while nebulae images are being loaded, i.e. quit while the "loading nebulae" progress bar is visible. This is running 0.10.5 on Windows, but it will also affect older versions. (I wouldn't be surprised if this is the cause of some of the other crash reports, or that they were at least getting a combination of problems). I can't repeat on Linux, but that's most likely due to the images loading so fast I can't quit at the same time - too old, too slow :)

The problem originates in:
   StelSkyLayerMgr::SkyLayerElem::~SkyLayerElem()
Specifically with:
   progressBar->deleteLater();
Removing this eliminates the crash.

I haven't had a chance to look at why this is happening (or exactly what is happening during loading of images) but someone familiar with this section of code can probably fix it easily. (As a side note, I did try adding a check for the app closing here, but Qt never reported that it was in fact in the process of closing as I would have expected it to - need to look into that.)

Peter

Peter Mousley (scrupeus) on 2010-07-01
description: updated
Peter Mousley (scrupeus) wrote :

Although I only mentioned loading of nebulae, it may also occur when loading other objects that use the progress bar (although I haven't been able to get it to crash while downloading satelite TLE data, so possibly not).

Changed in stellarium:
status: New → Confirmed
importance: Undecided → Medium
Changed in stellarium:
milestone: none → 1.0.0
Alexander Wolf (alexwolf) wrote :

Somebody can reproduce this issue on latest Stellarium?

Changed in stellarium:
milestone: 1.0.0 → none
Keatah (keatah) wrote :

6 out of 7 times I was able to reproduce this. I have no idea what in the 7th test, where it exited normally, was different.

Alexander Wolf (alexwolf) wrote :

Keatah, which version you used for test?

gzotti (georg-zotti) wrote :

Is this still unsolved with 0.13?

Alexander Wolf (alexwolf) wrote :

I don't know, I can't reproduce this issue

gzotti (georg-zotti) on 2014-08-11
tags: added: old
tags: added: crash
tags: added: windows
gzotti (georg-zotti) wrote :

Keatah, can you please test this with 0.15.2 or (better) the latest beta? I cannot reproduce it on my notebook (loading textures too fast...) and not even on my netbook (here I am pretty confident I pressed before the texture loading bars were finished). I set this to incomplete for now, it may have been fixed.

Changed in stellarium:
status: Confirmed → Incomplete
importance: Medium → Low
Keatah (keatah) wrote :

I should be able to test it mid-week. I'll report back then.

Keatah (keatah) wrote :

I tried to replicate the crash-on-exit while-loading-textures bug and was NOT able to do so. This on 0.16 released a few days ago.

I will try and make it fail on a couple of other machines.

Keatah (keatah) wrote :

Must be fixed. Can't make it fail. Tried on some slower mid-range machines too.

Launchpad Janitor (janitor) wrote :

[Expired for Stellarium because there has been no activity for 60 days.]

Changed in stellarium:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers