Scrolling inside windows messes its content color

Reported by faluco on 2010-06-04
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Stellarium
Low
Alexander Wolf

Bug Description

After the release of 0.10.5, i've noticed that when you scroll up and down, for example in the help->keys window, the content color of the window start to vary in different grey tones.
Scrolling with the mouse wheel doesnt reproduce the issue, but dragging the scroll bar will do it.
I didn't notice this while beta testing the release, so this issue was introduced in the latests revisions before release, i suspect it may be related with revs 6442 or 6449 but i havent tested them.

I've attached a screenshot to show the problem

Related branches

faluco (borja-ferav) wrote :
treaves (treaves) wrote :

I see this on my Mac as well. The same happens if you click the arrows on the scroll area to scroll. I'm using Qt 4.7.0 beta 2.

Changed in stellarium:
importance: Undecided → Low
status: New → Confirmed

I have seen this on the Linux version quite recently. QT 4.7.0 in Ubuntu 10.10. Seems to be a problem with all scrollablle QTextBrowser widgets. Looks like some funky interaction between the QWidget stylesheet using a qlineargradient and the background setting in the QTextBrowser stylesheet.

Changed in stellarium:
milestone: none → 1.0.0
Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → Fix Committed
treaves (treaves) on 2011-06-25
Changed in stellarium:
milestone: 1.0.0 → 0.11.0
Changed in stellarium:
status: Fix Committed → Fix Released
Bogdan Marinov (daggerstab) wrote :
no longer affects: stellarium/0.11
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments