Twinkle creates visual disaster

Reported by crn on 2010-01-30
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Stellarium
Critical
Unassigned

Bug Description

In 0.10.3, where stars should be twinkling, there are flashing boxes all over the screen. Very ugly and seizure-inducing. Was not an issue in 0.10.2.

Screenshot: http://yfrog.com/izstellarium001p

LOG:
2010-01-29T20:55:02
Windows XP
Compiled with GCC 4.4.0
Qt runtime version: 4.6.1
Qt compilation version: 4.6.1
Addressing mode: 32-bit
Total memory: 2046 MB (unreliable)
Total virtual memory: 2047 MB (unreliable)
Physical memory in use: 42%
Processor speed: 2188 MHz
Processor name: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Processor speed: 2188 MHz
Processor name: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
C:\Program Files\Stellarium\stellarium.exe
 -------------------------------------------------------
[ This is Stellarium 0.10.3 - http://www.stellarium.org ]
[ Copyright (C) 2000-2010 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "C:/Documents and Settings/HP_Administrator/Application Data/Stellarium/log.txt"
File search paths:
  0 . "C:\Documents and Settings\HP_Administrator\Application Data\Stellarium"
  1 . "."
Attempting to use an existing older config file.
Config file is: "C:\Documents and Settings\HP_Administrator\Application Data\Stellarium/config.ini"
Cache directory is: "C:\Documents and Settings\HP_Administrator\Local Settings\Application Data\stellarium\stellarium\cache"
Sky language is "en"
Application language is "en"
Loading Solar System data ...
Loaded 38 / 38 planet orbits
Loading star data ...
"Loading "./stars/default/stars_0_0v0_1.cat": 0_0v0_1; 5013"
"Loading "./stars/default/stars_1_0v0_1.cat": 1_0v0_1; 21999"
"Loading "./stars/default/stars_2_0v0_1.cat": 2_0v0_1; 151416"
"Loading "./stars/default/stars_3_1v0_0.cat": 3_1v0_0; 434064"
"Loading "C:\Documents and Settings\HP_Administrator\Application Data\Stellarium/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
"Loading "C:\Documents and Settings\HP_Administrator\Application Data\Stellarium/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
Finished loading star catalogue data, max_geodesic_level: 5
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Use vertex shader for stars rendering
QGLShader::link: "Fragment shader(s) linked, vertex shader(s) linked."
Warnings while linking shader: "Fragment shader(s) linked, vertex shader(s) linked."
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 222 / 222 NGC name records successfully
Use vertex shader for atmosphere rendering: "./data/shaders/xyYToRGB.glsl"
QGLShader::link: "Fragment shader(s) linked, vertex shader(s) linked."
Warnings while linking shader: "Fragment shader(s) linked, vertex shader(s) linked."
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Creating GUI ...

crn (crn) wrote :
oszukista (oszukista) wrote :

I have the same problem.
More data in attachment.

Please can you say what video card you have?

Also, please can you try the following:

Open a cmd window (run "cmd.exe")

Then type in:

cd "\Program Files\Stellarium"
stellarium --graphics-system=opengl

See if it makes a difference. Also please replace the last line with these:

stellarium --graphics-system=native
stellarium --graphics-system=raster

If any of them works, please say which one. Thanks!

TrainZer (trainzer-108) wrote :

No one of them works for me.

oszukista (oszukista) wrote :

None of them works with ati radeon 9550.

crn (crn) wrote :

@Matthew Gates

Computer:
      Computer Type ACPI Multiprocessor PC
      Operating System Microsoft Windows XP Media Center Edition
      OS Service Pack Service Pack 3
      Internet Explorer 8.0.6001.18702 (IE 8.0)
      DirectX 4.09.00.0904 (DirectX 9.0c)

Motherboard:
      CPU Type DualCore AMD Athlon 64 X2, 2200 MHz (11 x 200) 4200+
      Motherboard Name MSI Amethyst-M
      Motherboard Chipset ATI Radeon Xpress 200/1100/1150, AMD Hammer
      System Memory 2048 MB (PC3200 DDR SDRAM)

Display:
      Video Adapter ATI Radeon X300/X550/X1050 Series Secondary (128 MB)
      Video Adapter ATI Radeon X300/X550/X1050 Series (128 MB)
      3D Accelerator ATI Radeon X300/X550/X1050 (RV370)
      Monitor LG L226WT (Analog) [22" LCD] (1612133668)
      Driver/version ATI Technologies Inc. / 8.593.100.0

Multimedia:
      Audio Adapter Realtek ALC658 @ ATI SB400 - AC'97 Audio Controller

DMI:
      DMI BIOS Vendor Phoenix Technologies, LTD
      DMI BIOS Version 3.47
      DMI System Manufacturer HP Pavilion 061
      DMI Motherboard Manufacturer MSI
      DMI Motherboard Product AMETHYST-M
      DMI Motherboard Version 1.0

==========

None of the command lines (openGL, native, or raster) make any difference in the display for me.

Fabien Chéreau (xalioth) wrote :

Hi,
It seems that you have broken OpenGL shaders support. Try adding
use_glshaders = false in the [main] section of the config file:
C:\Documents and Settings\HP_Administrator\Application
Data\Stellarium/config.ini
Fabien

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
importance: High → Critical
milestone: none → 0.10.4
crn (crn) wrote :

@Fabien Chéreau

"use_glshaders = false" corrects the issue for me. Thank you so much!! That's the best product support that I've ever seen in terms of responsiveness.

Fabien Chéreau (xalioth) wrote :

Thanks :)
If you find out that updating your drivers fixes the problem, please report so that we can close the bug.
Fabien

crn (crn) wrote :

Updating the video drivers was the first thing that I did, so all I can say right now is that the current and previous ATI drivers for the X550 do not resolve the issue. As this is a legacy graphics card, driver updates are only 3 or 4 times per year at most, but I will continue to monitor.

TrainZer (trainzer-108) wrote :

"use_glshaders = false" corrects the issue for me too. But the text on the bottom panel still seems to be blurred.

oszukista (oszukista) wrote :

Affirmative - "use_glshaders = false" works for me too.
Thank you so much for helping me :)

astrohardy (fb4a042) wrote :

I reported the same problem, and the "glshaders=false" completely solved the issue. The problem has apparently nothing to di with outdated videodrivers, as I used the latest ones available for my 9600 TX Radeon card.

Thanks for the rapid response. Steallarium 10.3 is just great.

Hartwig

mitaccio (mitaccio) wrote :

I am experiencing the same issue. Everything looks fine on my Windows 7 laptop until I zoom in. Then the stars become squares just like the image up top. At that point my computer becomes unresoponsive and Windows closes the application. 0.10.2 does not have this issue.

Changed in stellarium:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers