subwindows sometimes do not appear

Bug #333931 reported by flx on 2009-02-24
4
Affects Status Importance Assigned to Milestone
Stellarium
Low
Unassigned
VirGO
Low
Unassigned

Bug Description

subwindows (e.g. F2, F5, F6) do not appear in certain occasions on dual screen set-ups.

How to reproduce: open virgo, toggle full screen mode (F11) and shift the VirGO main window to an other screen. F2, F5, F6 will not work. If a sub window has been opened before the move, then this window will be working also afterwards. (system: linux)

Update: The problem appears to be entirely due to the dual-screen setup. If VirGO is started on "screen 2", then without dragging, the subwindows do not appear.

Tags: old Edit Tag help
flx (flxst) on 2009-02-25
description: updated
Fabien Chéreau (xalioth) wrote :

There was a commit in Stellarium trunk which may have fixed this bug. TBC

Changed in virgo:
importance: Undecided → Low
status: New → Confirmed
Changed in stellarium:
importance: Undecided → Low
Fabien Chéreau (xalioth) wrote :

See also this comment from Bogdan Marinov on Stellarium devel list:
----
Something has to be done about the way Stellarium handles dual display
set-ups. See for example this bug:

http://sourceforge.net/tracker/?func=detail&aid=2836754&group_id=48857&atid=454373

The QDesktopWidget class may prove to be useful in this case:

http://doc.trolltech.com/4.5/qdesktopwidget.html

Changed in stellarium:
status: New → Confirmed
Changed in stellarium:
milestone: none → 1.0.0
Changed in stellarium:
milestone: 1.0.0 → none
gzotti (georg-zotti) wrote :

Has the commit from 2009 fixed the problem? We should close this (fix released or won't fix?) if it's useless.

tags: added: old
Alexander Wolf (alexwolf) wrote :

No, because current implementation doesn't allow appears for the subwindow outside main window. We really should work for this task (support of multimonitor systems).

gzotti (georg-zotti) wrote :

If you mean a main window that spans several monitors, e.g. an AMD EyeFinity system can do that. What about the original bug description? When I (Win7) start Stellarium on a dual-screen setup (no EyeFinity or similar setup), it starts on screen one. I leave full-screen, shift the window to screen 2, enter fullscreen (which covers screen 2 now), and the panels *work*, so I see no bug here. What about Linux?

The current inplementation of panels always has them painted into the main graphics, apparently this was intended around 2008/09. Having separate panels was a long-time wish of myself, this requires re-writing basic GUI components, but I'd regard that as wishlist or blueprintable thing to be discussed in a new item.

gzotti (georg-zotti) wrote :

The bug described is not reproducible eight years later. Dual-screen setups on Windows and Ubuntu (nvidia driver) work. Panels are in the main window by design. In sum, the bug has been solved between 2009 and 2015. There is no reason to keep this report alive.

Changed in stellarium:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.