Ocular Plugin malfunction in v16.1

Bug #1724106 reported by Paul Read on 2017-10-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Alexander Wolf

Bug Description

Since installing v16.1 (Win64) a bug has manifested in the Ocular Plugin where the target object moves away from the centre of view and begins to 'drift' when an element of the ocular is changed i.e. eyepiece or telescope. What is very odd, is that a SECOND change of element returns the target object to the centre of view. A third change and it will again drift. In some cases (dependent on the field of view available) the change of element will result in the target object being moved to outside the field of view completely. Consistently, the error occurs only on alternate changes (1, 3, 5, 7 etc and not on 2, 4, 6 etc)

I have not yet had chance to test the telescope control plugin for any similar bug - hopefully there is none!

The bug in the Ocular plugin is consistent and easy to replicate - I have done so on three other PCs using Wiondows 10 and Windows 7 and all with different CPU/GPU configurations.

There are several reports of this bug currently in the Forum, but surprisingly I cannot see a bug report for it here. This has only started to happen since moving from v16.0 to v16.1

Related branches

Changed in stellarium:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.17.0
tags: added: oculars plugin
Alexander Wolf (alexwolf) wrote :

A fix of this issue has been committed as revision 9886.

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers