OSX: Custom markers are not placed where the user clicks

Bug #1688985 reported by Snow Sailor on 2017-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Alexander Wolf

Bug Description

Using: 15" MacBook Pro from 215 with Retina display.
OS: OSX 10.10.5

Example of issue: If I click the very center of the screen to place a custom marker, the marker is placed in the center of the 2nd quadrant of the screen (Reference: http://images.slideplayer.com/16/4951540/slides/slide_2.jpg ). If I click the very bottom right of the screen, the marker is placed at the origin (center of screen). Could this be the result of some assumption that my screen is 1400x900px like previous MacBook Pro models (without retina display). Retina displays have 2800x1800 dislpays, so perhaps this is the cause.

Related branches

Alexander Wolf (alexwolf) wrote :

Please check Pointer coordinates plugin also.

gzotti (georg-zotti) wrote :

Markers are a rather new feature, and none of the 3 currently active of us have a Mac with Retina display or other HiDPI device. HiDPI display issues can only be tackled by somebody having a HiDPI display. We 3 don't have one. You deal with markers already and have a HiDPI screen, maybe you can add a fix also here? There were some additions/adjustments for HiDPI/Retina/4k, but Alex knows more where in the code they may be. Fixes for the markers will likely be similar.

Alexander Wolf (alexwolf) wrote :

Please check the trunk.

tags: added: mac-os-x
Changed in stellarium:
milestone: none → 0.16.0
importance: Undecided → Medium
gzotti (georg-zotti) on 2017-05-25
tags: added: 4k
gzotti (georg-zotti) wrote :

Snow Sailor, you have a Mac with 4k display and know about the Marker behaviour now. Is this problem still open in trunk, can it be circumvented with any of the 4k tips from the FAQ, or can you please even solve it with another patch?

Snow Sailor (snowsailor) wrote :

From what I can tell after downloading the latest version of the software, custom markers are all placed in the bottom left corner of the screen. That would be position (0,0) if the screen was the 1st quadrant on the XY plane. I have no idea what the issue is there. It seems that whatever was done in a prior commit messed it up even more than it was before (where it was placing the markers about half way where they should have been).

Alexander Wolf (alexwolf) wrote :

Please update StelCore::getMouseJ2000Pos() method for 4K monitors.

Alexander Wolf (alexwolf) wrote :

Please check revision 9557 - I hope I've fixed the issue.

Snow Sailor (snowsailor) wrote :

Alex, this is a screenshot after updating: https://puu.sh/wmpj5.png
What I did was I started out from the upper left of the screen and placed a marker. Then I placed markers along the diagonal line going from the top left to the bottom right. I made sure to start the marking in the very upper left and also end the marking in the very bottom right.

Something is definitely still off.

Alexander Wolf (alexwolf) wrote :

> Alex, this is a screenshot after updating: https://puu.sh/wmpj5.png

The current trunk or no?

Snow Sailor (snowsailor) wrote :

Current master, yes. Before I updated every single marker would be placed in the bottom left corner no matter where I clicked.

Alexander Wolf (alexwolf) wrote :

Please check revision 9558

Snow Sailor (snowsailor) wrote :

Now we seem to be back to what the issue was originally. This is the same pattern (from all the way in the upper left to all the way in the lower right): https://puu.sh/wmr6k.png

Snow Sailor (snowsailor) wrote :

The good news is that the exact location of the issue is known. Sometimes that's the most difficult thing to figure out.

Alexander Wolf (alexwolf) wrote :

Please check revision 9559

Alexander Wolf (alexwolf) wrote :

Any news please.

Snow Sailor (snowsailor) wrote :

Sorry. I had to go to bed. I've pulled and recompiled. This is the same pattern: https://puu.sh/wmMz7.png
It looks like the markers only go 1/4 of the way across the screen now (used to go 1/2 of the way). It seems that if you just do the opposite of what you did, they should stretch all the way across the screen.

Changed in stellarium:
status: New → In Progress
Alexander Wolf (alexwolf) wrote :

Please check revision 9563

Snow Sailor (snowsailor) wrote :

Perfect. Works exactly as it should now. Thanks for getting that figured out.

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers