.15 Crashes after 30 seconds for some users, Win 7

Bug #1667703 reported by Daniel Norton on 2017-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Alexander Wolf

Bug Description

I have installed Steallarium .15 on a users computer and I am able to run it without any issues. However, when the user logs in the program crashes after about 30 seconds. I changed the permissions in the program files and in the registry to grant her full access but that hasn't solved the problem. Any idea what could be causing this?

Related branches

Alexander Wolf (alexwolf) wrote :

Please attach a log.txt file. Could you describe situation, when Stellarium is crashed?

Daniel Norton (nortond) wrote :

Sure. I have attached a text file of the error in the event viewer. When the user opens the program, she is able to use all of the functions normally for around 15 - 30 seconds. After that a window pops up saying "Stellarium an open source software has stopped working" and the program closes. This is a typical windows "program has stopped responding" box. I have tried running it as the user using all of the alternative modes (ANGLE, MESA,etc) but the problem is the same each time. Meanwhile, if I as an administrator log into the computer, I can run the program fine and the error never pops up.

I tried changing the permissions but that didn't seem to fix anything. And if it was a permissions issue, I don't think the program would start at all, correct?

Odd question, but when Stellarium runs does it check back in with your company? Users can't access your website due to our filters but administrators, like myself, can. Maybe if the program is checking in with you guys the web filter causes it to crash? I'm just speculating at this point.

Alexander Wolf (alexwolf) wrote :

Please try disable all plugins and run it again.

gzotti (georg-zotti) wrote :

Some plugins like satellites auto-update data files, yes. And there is an IP/location query (can be switched off in the location panel).

Daniel Norton (nortond) wrote :

The program crashes a few seconds after I open the plug-ins menu. As a result, I can't tell if any are even enabled. Is there a mass disable feature?

Daniel Norton (nortond) wrote :

I disabled the location query but the problem has persisted. I can't tell which if any of the other plug ins are running. How should I tell?

gzotti (georg-zotti) wrote :

If all else fails, you can disable the plugins by editing the config.txt in your user data directory.

Daniel Norton (nortond) wrote :

Hi guys, thank you for your help. I believe I have solved the issue. The satellites plug-in was checking in with your site and that's what was causing the crashes. I hope this information helps someone else in the future.

Alexander Wolf (alexwolf) wrote :

Please try enable Satellites plugin (to get a crash) and run Stellarium. After crash please find log.txt file and attach them here.

Changed in stellarium:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 0.15.2
Alexander Wolf (alexwolf) wrote :

A tentative fix has been committed as revision 9171 of the trunk branch in Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/9171

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers