Oculars plugin crashes program

Bug #1653315 reported by Mike Neumann on 2016-12-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Stellarium
High
Alexander Wolf

Bug Description

Stellarium ver.0.15.1
Oculars plugin fails as follows:
Making changes to menu on Sensor tab or selecting "Image sensor frame" results in error dialog "A Problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

This plugin (using same oculars.ini) works properly using Stellarium ver.0.14.3

Contents of log.txt:

2016-12-30T21:20:31
Windows 10
Compiled using MSVC++ 12.0 (Visual Studio 2013)
Qt runtime version: 5.6.2
Qt compilation version: 5.6.2
Addressing mode: 64-bit
Total physical memory: 8116 MB
Available physical memory: 5042 MB
Physical memory in use: 37%
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
Processor speed: 2394 MHz
Processor name: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
C:\Program Files\Stellarium 0.15.1\stellarium.exe
 -------------------------------------------------------
[ This is Stellarium 0.15.1 - http://www.stellarium.org ]
[ Copyright (C) 2000-2016 Fabien Chereau et al. ]
 -------------------------------------------------------
Writing log file to: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\log.txt"
File search paths:
  0 . "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium"
  1 . "."
Config file is: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\config.ini"
Detected: OpenGL "4.3"
Driver version string: "4.3.0 - Build 20.19.15.4474"
GL vendor is "Intel"
GL renderer is "Intel(R) HD Graphics 4600"
GL Shading Language version is "4.30 - Build 20.19.15.4474"
GLSL Version Number detected: 4.3
GLSL version is fine, we should not see a graphics problem.
Cache directory is: "C:\\Users\\MikeLaura\\AppData\\Local\\stellarium\\stellarium\\cache"
Sky language is "en_US"
Application language is "en_US"
Loading Solar System data ...
Loading star data ...
"Loading \".\\stars\\default\\stars_0_0v0_7.cat\": 0_0v0_7; 4979"
"Loading \".\\stars\\default\\stars_1_0v0_7.cat\": 1_0v0_7; 21806"
"Loading \".\\stars\\default\\stars_2_0v0_7.cat\": 2_0v0_7; 150850"
"Loading \".\\stars\\default\\stars_3_1v0_4.cat\": 3_1v0_4; 425807"
"Loading \"C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_5_2v0_1.cat\": 5_2v0_1; 7083058"
"Loading \"C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_6_2v0_1.cat\": 6_2v0_1; 24670782"
"Loading \"C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_7_2v0_1.cat\": 7_2v0_1; 50733321"
"Loading \"C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_8_2v0_1.cat\": 8_2v0_1; 92304337"
Finished loading star catalogue data, max_geodesic_level: 7
navigation/preset_sky_time is a double - treating as jday: "2451514.25001"
Reloading DSO data...
Loaded 10757 DSO records
Loading star names from ".\\skycultures\\western\\star_names.fab"
Loaded 702 / 702 common star names
Loading star names from ".\\stars\\default\\name.fab"
Loaded 4506 / 4506 scientific star names
Loading variable stars from ".\\stars\\default\\gcvs_hip_part.dat"
Loaded 6916 / 6916 variable stars
Loading double stars from ".\\stars\\default\\wds_hip_part.dat"
Loaded 16412 / 16412 double stars
Loading cross-identification data from ".\\stars\\default\\cross-id.dat"
Loaded 108278 / 108278 cross-identification data records for stars
Loading DSO name data ...
Loaded 279 / 405 DSO name records successfully
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 88 / 88 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Initializing basic GL shaders...
Creating GUI ...
Loaded plugin "CompassMarks"
Loaded plugin "Exoplanets"
[Exoplanets] Version of the format of the catalog: 1
[Exoplanets] loading catalog file: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\Exoplanets\\exoplanets.json"
Loaded plugin "FOV"
Loaded plugin "MeteorShowers"
MeteorShowersMgr: Loading catalog file: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\MeteorShowers\\showers.json"
Loaded plugin "NavStars"
Loaded plugin "Novae"
[Novae] version of the catalog: 1
[Novae] loading catalog file: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\Novae\\novae.json"
Loaded plugin "Oculars"
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\Oculars\\ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 3.1
Loaded plugin "Satellites"
[Satellites] loading catalog file: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\Satellites\\satellites.json"
Loaded plugin "SolarSystemEditor"
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TelescopeControl"
[TelescopeControl] Only embedded telescope servers are available.
[TelescopeControl] Adding device model: "Meade AutoStar compatible" "Any telescope or telescope mount compatible with Meade's AutoStar controller." "TelescopeServerLx200" 500000
[TelescopeControl] Adding device model: "Meade LX200 (compatible)" "Any telescope or telescope mount compatible with Meade LX200." "TelescopeServerLx200" 500000
[TelescopeControl] Adding device model: "Meade ETX70 (#494 Autostar, #506 CCS)" "Meade's ETX70 with the #494 Autostar controller and the #506 Connector Cable Set." "TelescopeServerLx200" 1500000
[TelescopeControl] Adding device model: "Losmandy G-11" "Losmandy's G-11 telescope mount." "TelescopeServerLx200" 500000
[TelescopeControl] Adding device model: "Wildcard Innovations Argo Navis (Meade mode)" "Wildcard Innovations' Argo Navis DTC in Meade LX200 emulation mode." "TelescopeServerLx200" 500000
[TelescopeControl] Adding device model: "Celestron NexStar (compatible)" "Any telescope or telescope mount compatible with Celestron NexStar." "TelescopeServerNexStar" 500000
[TelescopeControl] Adding device model: "Sky-Watcher SynScan (version 3 or later)" "Any Sky-Watcher mount that uses version 3 or later of the SynScan hand controller." "TelescopeServerNexStar" 500000
[TelescopeControl] Adding device model: "Sky-Watcher SynScan AZ GOTO" "The Sky-Watcher SynScan AZ GOTO mount used in a number of telescope models." "TelescopeServerNexStar" 500000
[TelescopeControl] loadTelescopes(): No telescopes loaded. File is missing: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\TelescopeControl\\telescopes.json"
[Satellites] starting Internet update...
qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_client_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_client_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_server_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_server_method
qt.network.ssl: QSslSocket: cannot resolve SSL_select_next_proto
qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
qt.network.ssl: QSslSocket: cannot resolve SSL_get0_next_proto_negotiated
[Satellites] writing to: "C:\\Users\\MikeLaura\\AppData\\Roaming\\Stellarium\\modules\\Satellites\\satellites.json"
[Satellites] update finished. 1557 / 1560 updated, 0 added, 0 missing or removed. 1565 source entries parsed.

Related branches

Alexander Wolf (alexwolf) wrote :

Please attach your ocular.ini file

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
  • ocular.ini Edit (1.2 KiB, text/plain; charset=UTF-8; name="ocular.ini")

ocular.ini is attached.

On 12/30/2016 10:53 PM, Alexander Wolf wrote:
> Please attach your ocular.ini file
>
> ** Changed in: stellarium
> Assignee: (unassigned) => Alexander Wolf (alexwolf)
>

Alexander Wolf (alexwolf) wrote :

Can't confirm crash on linux and windows 7 (both 64-bit)

Changed in stellarium:
milestone: none → 0.15.2
Mike Neumann (darknite) wrote :

Alex,

I just did an uninstall of 0.15.1, then a clean install. During install
process, I allowed Stellarium to remove all files from previous
installation.

The program crashed as soon as I clicked on the Image Sensor Frame.

Mike

On 1/1/2017 1:49 AM, Alexander Wolf wrote:
> ** Changed in: stellarium
> Milestone: None => 0.15.2
>

Alexander Wolf (alexwolf) wrote :

Please try just zoom the sky to value of less 5 degrees.

Mike Neumann (darknite) wrote :

Yes, zoom at 5° can crash the program, provided the time is set "just
so". At time of 7:12, zoom at anything <5° works okay.

At time of 6:33:37, the program crashes at 4.17°. This is repeatable.

Obviously, a lot of trial and error will need to be done to determine
exact relationship between time, zoom and crashes. I can assist with
that, but due to holiday weekend, it may take me a few days to evaluate.

Please let me know if you need that (or anything else), so that my time
is not unnecessarily used.

Mike

On 1/1/2017 8:24 AM, Alexander Wolf wrote:
> Please try just zoom the sky to value of less 5 degrees.
>

Alexander Wolf (alexwolf) wrote :

What?! Please give us your location.

Mike Neumann (darknite) wrote :

I am using Chicago, Ill, USA as the location, because that was the
default that Stellarium selected for me. I actually live at Traverse
City, MI, USA.

On 1/1/2017 10:26 AM, Alexander Wolf wrote:
> What?! Please give us your location.
>

Nick Fedoseev (nick-ut2uz) wrote :

Please check files in the folder
C:\Documents and Settings\User\AppData\Roaming\Stellarium\stars\default\".
Is there stars_4_1v0_1.cat or stars_4_1v0_2.cat?

In case of "v0_1", please try to kill (move) it and reload the star data from the internet (v0_2 will be loaded).

Mike Neumann (darknite) wrote :

The directory initially contained the following files:

/stars_4_1v0_1.cat/

//

/stars_5_2v0_1.cat/

//

/stars_6_2v0_1.cat/

//

/stars_7_2v0_1.cat/

//

/stars_8_2v0_1.cat/

//

/starsConfig.json/

After killing /stars_4_1v0_1.cat/ and copying /stars_4_1v0_2.cat/ to the
same directory, the problem went away. Everything appears to work now.

Thank you for your assistance.

Mike

On 1/1/2017 4:03 PM, Nick Fedoseev wrote:
> Please check files in the folder
> C:\Documents and Settings\User\AppData\Roaming\Stellarium\stars\default\".
> Is there stars_4_1v0_1.cat or stars_4_1v0_2.cat?
>
> In case of "v0_1", please try to kill (move) it and reload the star data
> from the internet (v0_2 will be loaded).
>

Changed in stellarium:
status: New → In Progress
Changed in stellarium:
assignee: Alexander Wolf (alexwolf) → nobody
Alexander Wolf (alexwolf) wrote :

Please check this issue on version 0.90.0.9115: https://launchpad.net/stellarium/trunk/0.90.0

Mike Neumann (darknite) wrote :

Version 0.90.0.9115 seems to work properly.

Mike

On 1/22/2017 4:42 AM, Alexander Wolf wrote:
> Please check this issue on version 0.90.0.9115:
> https://launchpad.net/stellarium/trunk/0.90.0
>

Changed in stellarium:
status: In Progress → Fix Committed
Alexander Wolf (alexwolf) wrote :

The problem is not related to Oculars plugin!

Changed in stellarium:
status: Fix Committed → In Progress
importance: Undecided → High
assignee: nobody → Alexander Wolf (alexwolf)
Alexander Wolf (alexwolf) wrote :

A final fix has been committed as revision 9148 of the trunk branch in Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/9148

Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments