Installer: garbled characters in German strings

Bug #1652515 reported by gzotti on 2016-12-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Low
gzotti

Bug Description

The non-ASCII characters in the newly translated strings in the installer (option page) are broken. Some text encoding issue...

Related branches

tags: added: windows
gzotti (georg-zotti) wrote :

trunk r9021 has a recoded file (ANSI, not UTF8). Hopefully this fixes the issue. I leave status "in progress" until beta installer available.

Changed in stellarium:
assignee: nobody → gzotti (georg-zotti)
status: Confirmed → In Progress
Changed in stellarium:
status: In Progress → Fix Committed
Alexander Wolf (alexwolf) wrote :

Please check this issue on version 0.90.0.9086: https://launchpad.net/stellarium/trunk/0.90.0

gzotti (georg-zotti) wrote :

The installer issue is solved. However, Qt5OpenGL.dll is missing from the package! This causes a link error (cannot find address for function XXX) with another version of the DLL in PATH, or likely else a DLL not found error. Copying the DLL from 0.15.1 solves this.

Alexander Wolf (alexwolf) wrote :

Stop! Qt5OpenGL.dll is removed from package as expected - see CMakeLists.txt:380

gzotti (georg-zotti) wrote :

Apparently we need the library. The error indicates it tries to access the function in another Qt5OpenGL.dll. No problem with the library from 0.15.1 in the package dir.

Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers