ِArabic strings cropped, Stellarium 0.13.70

Bug #1498616 reported by Khalid AlAjaji on 2015-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Medium
Alexander Wolf

Bug Description

Stellarium 0.13.70.1 for Windows (64-bit) based on Qt 5.4.2 (Visual Studio Express 2013; OpenGL) with audio support:

Arabic strings are cropped in various panels of the main program and plugins. Same happens for some strings in information popups.

An example image attached.

Related branches

Khalid AlAjaji (kajaji) wrote :
Alexander Wolf (alexwolf) wrote :

We refactored it in the trunk and I hope it fixed already.

Changed in stellarium:
milestone: none → 0.14.0
assignee: nobody → Alexander Wolf (alexwolf)
Alexander Wolf (alexwolf) wrote :

Yes, I can't reproduce the issue on Linux.

Khalid AlAjaji (kajaji) wrote :

Issue is still existing in Stellarium 0.13.71 for Windows (64-bit)

Alexander Wolf (alexwolf) wrote :

Please show screenshot from version 0.13.3 (or other version with correct strings)

Khalid AlAjaji (kajaji) wrote :

Compare 13.3 and 13.7x. Notice How delta T is cropped.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → Medium
Alexander Wolf (alexwolf) wrote :

It's bug in Qt, because I can reproduce issue with Qt 5.4.2 and 5.5.0, but not with Qt 5.3.2. Aargh...

For example:
https://bugreports.qt.io/browse/QTBUG-46244
https://bugreports.qt.io/browse/QTBUG-48005

Apparently support of arabic text is partially broken in Qt since version 5.4.0.

Changed in stellarium:
status: Confirmed → Opinion
assignee: Alexander Wolf (alexwolf) → nobody
Khalid AlAjaji (kajaji) wrote :

adding html right to left <P DIR=RTL> ... </P> solves the issue for tool tips (pop up info) and some panel strings.

Changed in stellarium:
milestone: 0.14.0 → none
Khalid AlAjaji (kajaji) wrote :

looks like issue is resolved in Qt 5.9
https://bugreports.qt.io/browse/QTBUG-48005

Changed in stellarium:
milestone: none → 0.16.1
assignee: nobody → Alexander Wolf (alexwolf)
status: Opinion → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers