Le chargement des catalogues complémentaires d'étoiles ne fonctionne pas

Bug #1379241 reported by DrôleDeZèbre on 2014-10-09
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Alexander Wolf

Bug Description

En versions 012.4 ou 0.13
Sous Windows Seven ou 8.1
En 32 ou 64 bits.
Testé sur trois machines différentes.

Le chargement du catalogue 5 (stars4) s'arrête à 78%.
La mise à jour n'est pas faite.

Dès l'installation de Stellarium, et avant même son premier démarrage, le fichier starsConfig.json
C:\Users\xxx\AppData\Roaming\Stellarium\stars\default
indique que les fichiers stars_4...cat à stars_8...cat font déjà l'objet d'une erreur de checksum MD5.

"url": "http://downloads.sourceforge.net/sourceforge/stellarium/stars_4_1v0_0.cat",
   "checksum": "3abe460ce558418dbdab9a251c173cc4",
   "checked": false
  }

Related branches

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
Alexander Wolf (alexwolf) wrote :

No, it's a problem within Stellarium - now Stellarium didn't recognize redirecting correctly.

Changed in stellarium:
milestone: none → 0.13.1
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 7080 of the trunk branch of Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/7080

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → Fix Committed
Alexander Wolf (alexwolf) wrote :

The fix was published with version 0.13.0.96

Changed in stellarium:
status: Fix Committed → Fix Released
Diego Cancela (dimaeh-net) wrote :

OpenSuSE has been updated to version 0.13.2 Stellarium however continued to have trouble loading the catalog Stars_4
:
************************************************** ****************************************
Error: File "stars / default / stars_4_1v0_1.cat" is corrupt, MD5 mismatch! Found "d41d8cd98f00b204e9800998ecf8427e" expected "7a3b8b3471a755661b6d3686eb4c7cc2"
************************************************** ****************************************
you could check the integrity of stellar catalogs
.
thanks

Alexander Wolf (alexwolf) wrote :

Diego, I checked Stellarium 0.14.0 (trunk) and I can't reproduce the issue.

Alexander Wolf (alexwolf) wrote :

What's about some technical info, like log file? I can't reproduce this issue a long time ago (and I've checked it again few seconds ago for versions 0.12.6 and 0.14.0). What exactly you made for reproducing the issue?

Diego Cancela (dimaeh-net) wrote :
Download full text (4.0 KiB)

Here attached registration
:

2015-05-09T13:45:42
Linux version 3.16.7-21-desktop (geeko@buildhost) (gcc version 4.8.3 20140627 [gcc-4_8-branch revision 212064] (SUSE Linux) ) #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539)
Compiled using GCC 4.8.3
Qt runtime version: 5.4.1
Qt compilation version: 5.3.2
Addressing mode: 64-bit
MemTotal: 32736736 kB
MemFree: 25373920 kB
MemAvailable: 29444080 kB
SwapTotal: 67082496 kB
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 2700.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 3600.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
model name : AMD FX(tm)-8150 Eight-Core Processor
cpu MHz : 1400.000
/usr/bin/stellarium
 -------------------------------------------------------
[ This is Stellarium 0.13.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2014 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/dimaeh/.stellarium/log.txt"
File search paths:
  0 . "/home/dimaeh/.stellarium"
  1 . "/usr/share/stellarium"
Config file is: "/home/dimaeh/.stellarium/config.ini"
Detected: OpenGL "3.0"
Driver version string: "3.0 Mesa 10.3.7"
GL vendor is "X.Org"
GL renderer is "Gallium 0.4 on AMD RS780"
GL Shading Language version is "1.30"
MESA Version Number after parsing: 10.3
Mesa version is fine, we should not see a graphics problem.
GLSL Version Number after parsing: 1.3
GLSL version is fine, we should not see a graphics problem.
Cache directory is: "/home/dimaeh/.cache/stellarium/stellarium"
Sky language is "es_ES"
Application language is "es_ES"
Loading Solar System data ...
Loading star data ...
"Loading "/usr/share/stellarium/stars/default/stars_0_0v0_5.cat": 0_0v0_2; 4963"
"Loading "/usr/share/stellarium/stars/default/stars_1_0v0_5.cat": 1_0v0_2; 21598"
"Loading "/usr/share/stellarium/stars/default/stars_2_0v0_5.cat": 2_0v0_2; 150090"
"Loading "/usr/share/stellarium/stars/default/stars_3_1v0_3.cat": 3_1v0_3; 428466"
Found file "/home/dimaeh/.stellarium/stars/default/stars_4_1v0_1.cat" , checking md5sum..
Error: File "stars/default/stars_4_1v0_1.cat" is corrupt, MD5 mismatch! Found "d41d8cd98f00b204e9800998ecf8427e" expected "7a3b8b3471a755661b6d3686eb4c7cc2"
Finished loading star catalogue data, max_geodesic_level: 3
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 421 / 421 NGC name records successfully
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 338 / 338 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4502 / 4502 scienti...

Read more...

Alexander Wolf (alexwolf) wrote :

Are you tried re-fetch it within Stellarium?

Diego Cancela (dimaeh-net) wrote :

Indeed I tried to load the catalog from within Stellarium

Diego Cancela (dimaeh-net) wrote :

I installed the new version of Stellarium 0.13.3-32.1 distribution OpenSuSE repository education, and achieved Stars_4 successive load the catalog.

Thank you all.. .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers