No disk in station F on start

Bug #1371183 reported by OvV on 2014-09-18
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Alexander Wolf

Bug Description

Starting Stellarium 0.13 on a (NL-dutch) Windows 8.1 64-bits computer (fully updated as of Sept. 18, 2014) gives immediately after the splash screen an error dialog complaining that there is no disk in a station F.
I can click on a button Continue (NL: 'Doorgaan'), but then 8 more times the same error dialog appears.
After the 9th dismissal of this error dialog, Stellarium can be used as expected.
This stupid behavior renders Stellarium useless.
No problem with Stellarium 0.12.
No problem whatsoever with more than 120 application programs on my Windows 8.1 computer.
IMHO it is a Stellarium 0.13 compatibility problem, whatever the dear developers wish to think.
Alas: I have no clue whatsoever about the cause of the problem.

OvV (ovv123) wrote :
Alexander Wolf (alexwolf) wrote :

Please attach log.txt & config.ini files

tags: added: windows
OvV (ovv123) wrote :

Attached the combined requested files from the path:
C:\Users\....\AppData\Roaming\Stellarium
(blanked user name, also in log.txt)

gzotti (georg-zotti) wrote :

This "missing disk in drive <whatever>" problem has been reported before. Stellarium does not ask for a disk in what may be a removable drive (F:?) in its own code as far as I know. It appears to be a misconfiguration in some Windows systems. Also other programs are affected when I Google for the error string, and I thought we can do exactly nothing here, as long as we cannot reproduce this! (It works on my own Win8.1 netbook.) Some Windows forums may give further help.

What puzzles me however is that as you describe, after a few "Continue"s, it works?

Have you started with a fresh installation, i.e. no left-over config files from 0.12.*?

OvV (ovv123) wrote :

It's a real pain, not being able to reproduce the error.
Still, I think it's a problem caused by Stellarium or the compiler used.
I merely downloaded your installer and ran it.
I got the impression that there are no left overs.
Then again: your installer should check this.
I have a rather clean Windows 8.1 system; nothing changed in the drive letters. C is my boot & application disk. Drives E and F are meant for USB drives if present (none present), and G is for the DVD-drive (drive is OK, no disk present). A configuration like this is pretty normal for Windows systems, at least the last decade or so.
After dismissing precisely 9 error dialogs, Stellarium seems to work normally. The active plugins (just the ones out of the box) seem to work.
Something in Stellarium is since version 0.13 configured in such a way that it looks for something in drive F.
No other of my non-Microsoft desktop application programs (some tens of them) is producing this error.
It really looks like a mysterious configuration problem in Stellarium, one of its plugins, your compiler or installer maker.

I know, all of the above is probably not really helpful. Please keep checking with your thinking cap on!

Alexander Wolf (alexwolf) wrote :

Can you disable all plugins in config.ini and check it again? Can you check 0.13.0.84 also?

Changed in stellarium:
importance: Undecided → Medium
OvV (ovv123) wrote :

plugins_load_at_startup in config.ini: all false -> absolutely no difference. Still the same number of error dialogs.

OvV (ovv123) wrote :

Downloaded stellarium-0.13.0.84-win64.exe and installed it just like the installer suggested, so nothing checked in the remove files section.
Result: NO MORE ERROR DIALOGS ON START!
Previously set configurations like location and loaded plugins: no problem, loaded as expected.

Probably the "no disk" problem is solved!
Thanks!!!

Changed in stellarium:
status: New → Fix Committed
milestone: none → 0.13.1
Changed in stellarium:
status: Fix Committed → Fix Released
Nick Fedoseev (nick-ut2uz) wrote :

The same problem remains with 0.13.1 after installation over old 0.13.0 and/or after usual uninstall 0.13.0 and new installation.

Perhaps it is useful: the first launch after reinstallation is good, the second one begins with above mentioned serie of 9 "No disk" dialogs.

I could fix the problem after deep manual cleaning misc Appdata folders from old user data in order to get clean install. Seems that there is a folder name or file name somewhere in .ini or app cache, which is phisically absent, and Stellarium tries to find it on every disk in the system, including empty CD drives.

Changed in stellarium:
status: Fix Released → Confirmed
importance: Medium → High
milestone: 0.13.1 → 0.13.2
Alexander Wolf (alexwolf) wrote :

A tentative fix has been committed as revision 7116 of the trunk branch of Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/7116

A fix require testing.

Changed in stellarium:
status: Confirmed → In Progress
assignee: nobody → Alexander Wolf (alexwolf)
Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers