Wish List Item - Previously Requested - Oculars - Permanent Crosshairs

Bug #1364139 reported by Robert Van Vugt on 2014-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Wishlist
Alexander Wolf

Bug Description

I had requested this before and I think it was to be incorporated in v13 but I do not see it. What I thought would be a good idea was to incorporate a small checkbox in the ocular setup window such as the binocular checkbox that would allow a ocular to display constant crosshairs as some eyepieces are permanent crosshair eyepieces and the crosshairs can not be removed from them. This way when entering your crosshair ocular info you can designate it as a special crosshair eyepiece. I see the added celestron eyepiece with the red marking scales but that is not what I had intended but that too is a nice addition for those of us that have that specific eyepiece. But my idea is to just enable the crosshair feature that already exists permanently on any select eyepiece in the individual ocular setup/settings.

Thanks for Listening
Robert

Related branches

gzotti (georg-zotti) on 2014-09-02
Changed in stellarium:
importance: Undecided → Wishlist
tags: added: oculars plugin
Alexander Wolf (alexwolf) wrote :

Robert, can you give list of types of crosshairs?

Changed in stellarium:
status: New → Confirmed
assignee: nobody → Alexander Wolf (alexwolf)
Robert Van Vugt (rvvcuda) wrote :

I guess you folks are just not understanding what I am requesting here. I am not sure I can explain it any better than I already have but I will try again.

The way it is right now a user needs to turn on crosshairs buy clicking on the crosshair button and a standard crosshair is displayed on whatever eyepiece is being used. My request is to be able to check a box when entering the data for a custom eyepiece that will enable the crosshairs you already have as part of Stellarium to be assigned permanently for that eyepiece. Actual Crosshair eyepieces cannot have the crosshairs removed so when I select my custom crosshair eyepiece it will already show the crosshairs and I would not have to turn them on manually by clicking the button. The crosshairs style displayed by Stellarium presently is fine, I just wish to be able to assign the crosshair feature to a custom eyepiece permanently in the same manner as the binocular checkbox in the ocular setup.

Does this help, do you understand what I am requesting ? I thought this would be easy to do since the crosshair feature is already there and it just would be nice to be able to turn it on permanently for a custom crosshair eyepiece.

By the way v13 of Stellarium does not work well with XP, lots of issues

Robert

Alexander Wolf (alexwolf) wrote :

Robert, I understand your request, but googling give me different "shapes of crosshair" for eyepieces.

Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 7087 of the trunk branch of Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/7087

Changed in stellarium:
milestone: none → 0.13.1
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers